Turnigy ia6 Reciever has huge latency all of a sudden


#1

i used to fly a 210 drone, which i lost and built a new one(270). when i went out to fly the 270 i all of a sudden had huge delays from the drone. i thought it was because of someone else flying close to me, but when flying the drone a day later i noticed the same problem: delays of up to 2 seconds and on small inputs even no response from the drone. after about a week or so after that someone found my 210 drone. i cleaned it and resoldered everything. when starting up my old drone though i noticed the exact same problem, aswell as some motor stuttering at high rpms. my drones tend to regain their reaction time somewhat after flying around for a couple of minutes though.(they still don’t fly as well as they used to: the gyros seem to change their opinion on whether down is at 90 or 86 degrees and at high rpms the drones don’t feel like they are correcting their attitude.) i’m pretty sure the problem is either with my radio or the betaflight software version.(or and this is a longshot: i use an sma antenna on one and a rp-sma antenna on the other drones fpv)
also: when i connect the drones to betaflight and look at the display i can clearly see the delay, so the problem isn’t with the escs or motors
specs:
TX: turnigy 9X
RX: turnigy ia6B on both drones
motors: rs2205 on both drones
fpv: eachine tx526 on both drones
fc: afroflight rev6 naze32 on both drones
software: betaflight naze (afna) 3.2.0 on both drones


#2

May there be an issue with your antenna mounting or are you flying behind hills or other solid objects?
Can you upload a picture of your Quad and a Video of you flying?
Is it possible that your Radio got damaged somehow?


#3

Delay on RC input or fpv feed? i assume rc input, 1st thing i would do is reflash firmware, also when i used naze32 i found 3.17 firmware better. give it a go and let us know.


#4

i did tests where i was just a couple of meters away from the drones. my older drone crashed pretty hard a couple of times but i have the latency issues with both drones.


#5

i tried looking for naze 3.17 and i used to have it on my old drone, but i can’t find it on BF, CF or generally as a download. do you know where i could download it from?


#6

If you are using naze 32 you should have not downloaded the latest version of betaflight as the naze 32 is not supported. you need to uninstall and download a older version 10.2 should do the job.


#7

ok this is weird.
on 10.5 naze isn’t an option. i downloaded 10.2 and i can’t find it anywhere under choose board on the flash page. i tried looking for downloadable firmware so i could flash locally but there’s nothing. is it normal to not have naze even on older versions?


#8

yep your correct for some reason its not there, use cleanflight 2.4 just checked and naze is defo there. use 2.1 firmware or below though.


#9

ok.
so i found the naze 3.20.hex for betaflight somwhere. i could not tell you where but i found it. i flashed my 210 and it worked immediately. there’s no more lag and the drone doesn’t all of a sudden freak out. i had to solder the boot pins on my 270 but it worked out too. i’ll have to do some more testing with long range, high Gs, etc. to see whether it truly works as well as it did. the only problem i have now is that some motors on both drones tend to “jitter” on high rpms which can cause an imbalance and therefore unwanted roll/pitch inputs. one theory i have is that my motor wires might be shorting since there’s more electricity flowing through the wires causing it to jump.


#10

Glad you sorted it ish, just try turning down your P term about 5 may help, without seeing it fly can’t really say