Aurora 90 with Qx7 Frsky having major Latency

aurora90

#1

Just received my Aurora 90 and bound it with my Qx7 frsky and had major latency comunication with the Aurora , so I flashed everything new , created new model and still having same issue. At one time, I had no channels enabled on Betaflight , but I finally got them back but still 1 sec delay remains, Please, I have no idea wha’s happening. I’m somewhat of a newbie, not great at troubleshooting.thanks


#2

Is this delay what you see in betaflight GUI on the receiver tab?

If that is the case then I suspect that it also takes a while to connect to your quad and also when you change from tabs in betaflight GUI it is not instant.

The usual cause for this is when you have a device connected to the same UART port as the usb on your flight controller. Usb is usually on uart1 of the flight controller, so just make sure your reciever is connected to another UART like 3.

Hope.that helps but if not can you give me some.more details of your setup like what Rx you are using, and is is sbus/ppm etc…


#3

Yes its in the Receiver tab, all channels are delayed or sluggish. I chose UARt 3 already at the beginning. Its SBUS , type o receiver i’m Not sure as its not telling me, its full OSD, likely XSR, not XM as I have that one on my King Kong and its D16, this one is D8…Hope that helps…


#4

Do you have anything else connected… The aurora 90 uses the minicube stack as far as I remember, so that should not be a problem.

The other thing I can think of is when you are connected along the bottom of the betaflight GUI there are some numbers, one of them is CPU load… what is yours saying?

Also if you try to arm (with props removed) are the stick inputs still delayed, as maybe its just a betaflight thing?


#5

Nothing else connected…I even unplugged the LEDs, CPU is 23% continuous and delay is like this even off Betaflight, this is how I found out , out of box I was getting a delay…so I flashed new firmware etc and same thing…I have King Kong 110 and it uses Xm D12 and works great on my transmitter, but this receiver is D8 , don’t know if there is something to do with it, It loses telemetry sporadically even when im 10 feet from it…so I have no idea what’s going on…could it just be a bad receiver…I was thinking of flashing with older firmware but since it came with an older firmware , did the same…arghh so frustrating…thanks for helping


#6

To be honest, if you are getting a delay even when not connected to your PC via USB then I am starting to think that something is faulty. I have not experienced this issue before (or I dont remember anyway). Maybe there is a setting that can fix this somewhere but I am not sure.

My only suggestion if you have some time is to try another receiver, or use the aurora90 receiver on another quad to see if you still get the latency. That way you can atleast find the problem to be on the receiver or not…


#7

Yup I’m thinking the same thing…I’’m not that electronically savvy , this is one of the cube stacks, so I think its as easy as desoldering the 3 points , removing it and adding another…not sure will have to research it…Time to learn…ANyways, hope its simple bad receiver as I did get a refund of 75% of what I paid for it…so not bad of a deal if I can get it to work…thanks for your help


#8

I have the same exact issues. Were you able to figure it out? Thanks!


#9

Just read on a dronetrest blog…

Try to rebind your RX it seemed to fix the issue for another user.


#10

Nope I tried to rebind several times and nothing worked…so I went ahead an bought a new receiver, the same one came with the Aurora but I still have not had a chance to install it…I think its the only way to fix this problem, unless there is something more going on…Let me know if you do the same and install a new receiver, they are like 20 bucks on Banggood. So not expensive…


#11

When you do get around to it :wrench: , please do update us on the outcome as I think it will help quite a few other people out who are in the same situation as you :slight_smile:


#12

From what I was told, its likely the problem, there have been some receivers on the Aurora…I can’t think of anythng else it could be as I did all the updates on my FRysky, Aurora, everyting …and asked dozens of people and everyone said just replace it…Hope I will be able to do it next few weeks…I’m just overwhelmed with work and traveling…I have flown any of my drones for months…Hey if anyone here decides to do it…same thing let us know…they are cheap to buy


#13

I bought and replaced a new receiver and still have the same issue. Have you had the chance to install yours? Any luck?