I can't get rid of pitch drift. ( Straight back )


#1

Eachine racer 130
BF 3.1.7 & 3.2RC3
Center of gravity is good.
Stock (PIDs)

Quad starts drifting back after a few seconds of flight. From a little drift to a lot of drift after a min of flight. After landing unarming and then rearming quad starts out good then goes thru the same cycle again. All indoor flight no wind.

All stick inputs on receiver tab are 1000 low, 1500 Center, 2000 high.
Using turnigy evolution with fs-a8s receiver.

I have flash and reflashed betaflight.
Could the location of the receiver be screwing with the accelerometer?
(CONFIRMED NOT RECEIVER POSITION)

Thanks in advance for any help.


#2

Could possibly be a stuck or damaged gyro sensor on your FC.
If you have had a few crashes (and we all do),it can be one of those “cant see whats wrong” scenario.
99.9% its a damaged sensor and a new FC will fix it.


#3

Or maybe this could be solved by some pid tuning ?
The following presumes a non self-level flight mode , but could be a starting point for self-level modes too.

First take note / copy of all settings as is then ,
Possibly try reducing the I term for pitch .
Maybe reduce by 50% ,
This may well cause forward-pitch drift.
So , adjust til I term is correct.


#4

I tend to agree with @Fpv that it’s probably a faulty gyro. All gyros drift with time, but if it’s damages it drifts alot more like yours :-(. So it will probably need to be replaced.

If it was a bad accelerometer it could.just be recalibrated via betaflight.


#5

can you do me a favor and send a picture of the setup? I am curious how close the FC is to the motors. I have experienced the same issues and it usually happened for me due to the position of the FC in relation to the center of the board and then the proximity of the mounting screws to the wings.


#6


#7

Ok and the controller you are using? Don’t need a pic yet…just want to know the controller.


#8

The flight controller is a naze32. I use a FS-A8S receiver with the turnigy evolution transmitter.

I havnt had much time to screw with it l lately I was going to reposition the receiver again then maybe soft mount the flight controller.

It worked great when I first got it but has been acting weird lately.


#9

Ok if you are referring to the naze32 rev6 I have experienced the same problem. I did remount the controller and also verify the board sat perfectly level. One way to do this to help is to get 1mm “neoprene” style sheet and cut it to fit the 30.5 hole pattern.

If you are located in the US, find a hobby lobby - they have then there for pennies. I am willing to send you an acro for free if you want to test a new board out. If it works - you can pay me and if not, then just send it back.

I also offer free remote access to check the clean flight / beta flight configs and assist so if you need that just let me know.