My quad is gaining height in unusual manner

I have been facing a problem. I have an X configuration ardupilot quadcopter. WHen I push my elevator stick forward the front motors that is the motors at the side of forward pointer of apm increase speed. But as per the instruction I found that the back motors should increase speed when I push the elevator stick forward. So I Reverse the elevator channel of my Turnigy 9x transmitter. But the problem now is when I pust the elevator stick forward my qauadcopter in gaining altitude at a high rate. if I push the alieron stick it is not ascending but slightly decending. BUt when I push the elevator stick forward it is gaining height.
can anybody tell me why this is happening? I am also attaching a photo explaining my frame and motor setup. I am using “X” configuration.

Are your motors connected to the APM outputs as per the diagram, does pushing pitch (elevator) forward speed up motors 3 & 1 when it should speed up 2 & 4 in your diagram?

To help diagnose transmitter config issues - if you are using mode 2 transmitter…

Left stick controls:

Up/ down = Throttle
Left/ right = Yaw (turn colockwise/ anticlockwise on the spot)

Right Stick controls:

Up/ down = pitch (tilt forwards/ backwards)
Left/ right = Roll (tilt left/ right)

First thing to try is connect APM to Mission Planner using USB, power up radio and go to Initial Setup -> Mandatory Hardware -> Radio Calibration. You do not need to power the model as the USB connection will power the APM.

Then move the sticks one axis at a time and make sure the correct indicator on screen moves with it. If not then that should give you an indication which channel needs to be altered.

Thanks @Louise for your helpful reply!

I agree that you should start off by looking at the radio calibration screen first as you might also find that your radio has got some mixing modes setup (that combine throttle with elevetor etc…)

If you are using the turnigy 9x, have you setup the flight mode to be for plane :airplane:, or helicopters :helicopter:? Its abit contradictory but to fly with arducopter you need to set your radio to a plane flight mode as the APM board does all of the mixing for you. Also please make sure there is no other mixing setup between your control sticks. (you can use mixing with teh flight modes sticks to get more channels, but for now its best to turn all the mixing off and start from there)

The other thing to check aswell is to make sure that all of your ESC’s are correctly calibrated. To check this when your first start the motors they should all startup at the same time. For more details on ESC calibration please go here

Thank you Louise and admin. I calibrated and check the mission planner radio calibration screen. Actually I am using the turnigy plush ESC. the processed described in this link
is not working with my trunigy.( i mean the beeps are not same).
So I caliberated the ESC separately. Can these cause any problem. and another thing is while takeoff my quad gets slighted tilted in the pitch axis and start flying. What could be the possible reason behind this?
with thanks

I am guessing if esc’s are not properly calibrated then that could cause the pitching, you would need to get the manual for the esc you have and figure what beeps you should get as you follow the process.

Another possibility for pitching is if a motor(s) is/are not mounted perfectly square to the plane of the motors - tilted slightly.

Do you have any trims set on the transmitter? You should have all trims centred or turned off when using APM.

I assume from…

" I calibrated and check the mission planner radio calibration screen."

That the radio is set up correctly and operating the correct channels as the sticks move?

thank you so much Louise. Actually my plush ESC which has a lots of programmable field was not properly programmed. one of my ESC was accidentally programmed to NI-Mh. aND the throttle range for that ESC wasn’t properly calibrated. So now when I HAVE done everything right alhamdulillah my quad is now flying pretty well than before.

Happy to hear its all working nicely :-D! If you get some time you should share a video of your flight!

Glad you have found the problem, sometimes you just cannot see the wood for the trees :smiley: