No 100% power on engines

apm
esc

#1

Hello everyone!
I have a problem with engine power in APM and I’m almost sure, that is problem of APM.

Details of my quadcopter are: ESC’s are Emax BLHeli 12A, 1A BEC, engines DYS BX1303-2300KV and RC system is Hitec Aurora9 Tx and Optima 6 Lite Rx.

My problem is as follows: After arming engines, I have no full power on them. I can push the throttle stick to about 50% and engines are reacting, but after 50% nothing happens.
Engines are not accelerating.

I’ve done of course MIN and MAX of throttle settings and during this calibration engines are accelerating to 100% of throttle stick. Seems to be okay, but when I disconnect power, connect it back and arm engines, there are no changes and still the same problem.

I even upload ArduPlane and ArduCopter software again, because I’ve read somewhere that this method is a cure for a lot of strange problems with APM, but it doesn’t help anyway…

PS: Engines and ESCs seems to be okay because I’ve test them on OpenPilot and on this platform engines react positive on full range of throttle stick and my quad flew on about 30 meters above ground and on APM only on about 1,5m.


#2

Have you performed a radio calibration with the mission planner software?


#3

Yes, I did. I’ve performed all steps of implementation of software and calibration (GPS, compass, radio, accelerometer etc.)

Strange thing is also, that in auto mode (AUTO, RTL) the quad is flying on about 1-1,5m above ground, but in settings I set 10m.

Combining of symptoms: 1. after 50% of throttle stick engines are not accelerating; 2. in AUTO modes quad flying on max 1,5m; > I suppose that there is something wrong with APM.

I’ve use this unit of APM, GPS, PM, RC on my moto-glider, and there were no problems in any auto mode. Maybe all my problems are induce by new software of ArduCopter?


#4

In auto, altitude or GPS hold modes the APM controls your throttle so that is prob why you can’t get 100%.

However if you are in manual/stabilised mode are you able to get 100% as in this mode you directly control thrust.

As for the RTH altitude, I would double check that parameter as maybe you entered it wrong. Otherwise you can check the logs to see of there was a sensor issue as you can see what alt APM thinks it was at when you entered RTH mode


#5

No, no. In all auto modes (RTL, etc.) I’m NOT using throttle stick. I’m saying that I’ve set the RTL_ALT (Return To Launch Altitude) parameter on 10m, but the quad can not go higher than 1-1,5m above the ground.

Mentioning about the same problem with the stick, I had on my mind STAB mode.


#6

One thing I forgot to say, is your RTL_ALT parameter… have you set the value to 15? Or rather 1500? As the values are in centimeters, so for 10 meters you will need to set the RT_ALT to 1000.

Hope that clears things up.


#7

I know, what you mean :slight_smile: I’ve input 1000cm, so 10m :smile:
As some classic said: trust me - I’m engineer ;p


#8

Finally!
I had to change THR_MAX from 1919 to 1000. Now, everything is ok, and engines are spinning and accelerating properly for full range of throttle stick :slight_smile:


#9

Thanks for sharing the solution :slight_smile: hope you have some fun flying!


#10

Boa noite estou com o mesmo problema e não consigo resolver , o maximo que o meu chega e 900 ha 1400 na calibração do radio