Help! Quadcopter not taking off!

apm
esc
multirotor

#1

Hi all!

So, I completed my drone build a couple of days ago, and when I decided to go on my maiden flight, it wouldn’t get off the ground.

What perplexed me is, in theory it should have more than enough thrust to take off. The all-up-weight is 2.65kg with two 4S LiPos (I even tried with a single LiPo to reduce weight, still no luck) and the total thrust should be in the region of 4.4-5kg for four 380KV motors and 16 inch props. I made sure to use 14AWG throughout the quad with good solders so wiring can’t be the issue. Here is the video below:

And these are the thrust charts for the Sunnysky 380KV motor:

My question is, what can I do to resolve the issue? I have tried resetting the THR_MAX value in MP to 1000. The props are 38g each, should I replace them with some lighter 17" ones? Is the ESC at fault? This has been a real head-scratcher, any help will be highly appreciated. Thanks in advance!


#2

Your props look to be in the correct positions/pitch
Are you motors rotating on the correct directions?
Can you share your parameters file?
Cheers
Steve :grinning:


#3

Yes I counterchecked everything, motor spin, prop direction, everything. I’m just not getting the thrust I need.

Ok will share the parameters file once I’m able to get it.


#4

Hi
Have you calibrated ESC’s?
It does not sound if motors are reaching maximum speed at full throttle
Cheers
Steve :grinning:


#5

I agree with @stevietee10, either its that your ESC;s are not calibrated to the full throttle range, or the APM is not fully calibrated for your AT10 radio (so even though your throttle stick is at 100%, APM might think its still at 30% or whatever.)

If you need some info on how to calibrate both just let me know.

Another issue, is that your props could be upside down, although in the photos I dont think this is the case.

Otherwise quite a cool looking frame, so hope we can help you get this in the air.


#6

I tried calibrating, though I do suspect I didn’t do it right, the sequence of beeps weren’t corresponding to those on the (rather vague) instruction manual. Is the beeping sequence the same for all BLHeli firmware ESCs? Thanks! :smile:


#7

Thanks for the help! Indeed it would be great to finally have it in the air :slight_smile:

I might actually need some guidance on how to program the ESC based on the beeps (LVC levels, brake mode etc). The ESC is an FVT Sky III 4-in-1 ESC running on BLHeli firmware if I’m not wrong. Any idea where I can get this information?


#8

It’s all in blheli manual:

Butblheli calibration is the same as most others, as discussed here


#9

@luide_kakembo
Hi
Are you using Mission Planner?
The ESC calibration in there is bit rubbish
I had another method which I’ll send you but not until this evening when back home, sorry.
@unmannedtech
Alex, can you confirm the end limit values to be set in the AT10II? It sounds from your post that it may be unusual. As I’ve just bought an AT10II from you I have a vested interested also :+1:
Cheers
Steve :grinning:


#10

@stevietee10 Hi, yes I do use Mission Planner, please do send the other option once you get the chance. Thanks! :slight_smile:


#11

Apologies, @stevietee10, just remembered this, Quad Parameters_MP.zip (1.9 KB)

This is my parameters file, do kindly let me know if anything seems out of place, thanks!


#12

Hi,

First thing…
1, make sure props are NOT fitted
2, the APM controller should NOT have USB cable connected
3, LiPo battery is NOT connected

Turn on your transmitter and put the throttle stick at maximum.(if stick is sprung to centre then find a way to hold it in maximum position.

Connect the LiPo battery. The APM’s red, blue and yellow LEDs should light up in a cyclical pattern. (this means the it’s ready to go into ESC calibration mode the next time you plug it in)

With the transmitter throttle stick still held high, unplug the battery, wait a few seconds then reconnect it

The APM is now in ESC calibration mode. (the red and blue LEDs should be blinking alternatively on and off)

Wait for your ESCs to emit the tones, the regular number of beeps indicating your battery’s cell count, one for each cell (i.e. 3 for 3S, 4 for 4S) and then an additional two beeps to indicate that the maximum throttle stick position has been recorded.

move the transmitter’s throttle stick down to its minimum position and keep it there.

The ESC’s should then give a long tone meaning that the minimum throttle position has been recorded

The calibration should now be complete.

If the long tone indicating successful calibration was heard, the motors are “live” now and if you raise the throttle a bit they should spin. Test that the motors spin by raising the throttle a bit and then lowering it again.

Set the throttle to minimum and disconnect the battery, this exits calibration mode.

In my experience I find it best to power up with the throttle at minimum position but this may just be something I have OCD about.:laughing:

Thanks to ardupilot documentation for this method
see also

Let us know how you get on, we want to see a video it flying
Cheers
Steve :slight_smile:

PS I’ll look at your parameters file later tonight :slight_smile:


#13

Hi, thanks for the instructions!

So, I’ve gone through the ESC calibration a countless number of times (directly from ESC to receiver and through the flight controller) and I’ve realised the throttle calibration isn’t actually the problem.

So I decided to test out the amp draw from the quadcopter at various throttle levels and compare it with the factory specifications for the Sunnysky 380KV motor, below are the results:

Clearly from the results there is a more serious problem, the ESC isn’t delivering the correct amount of current to the motors! Below is a video of the procedure.

Is there anything I may have done wrong with my testing, and is there anything that can be done to increase the current output of the ESC?


#14

Hi
I think you need to look at Alex’s @unmannedtech suggestion that your radio transmitter is not set up correctly. Check the end limits and make sure there are no trims or mixes that are reducing the PWM rate outputed for max stick position.
With the motor loaded with a prop you should see high top end currents
Plotting these numbers in a graph clearly shows you are not reaching full throttle
What do the bars indicate in MP? What numbers are being shown for min and max stick positions?
Do you have the black ESC signal wire connected or have you just used the white?
Steve :slightly_smiling_face:


#15

Apologies for getting back to you so late. But yes you can set the end points on the AT10, you just go to the menu and use the end-points menu. This allows you to set the start and end range (within 50% i think) so you can get your throttle to be exactly between 1000-2000 (or whatever you want)


#16

I disconnected the black wire :disappointed_relieved: I will try and reconnect it to the GND port on the APM board then redo my tests.

As for the transmitter signal, the APM detects about 1914 at 100% throttle (displayed in MP) but I will cross check the values and get back to you.


#17

Hi
1914 should give you plenty of throttle, enough to get off the ground anyway
Maybe your ESC’s are not reading the signal correctly without the signal reference (black wire)
I’m crossing my fingers that is it :slightly_smiling_face:
Steve


#18

Have you tried changing your props around.


#19

Hi, it was one of the first few things I tried, no luck with that.


#20

Hi, so I tried the ground cable option, even that still didn’t give me the punch I needed.

So, recently I tried testing with a 3S battery, the motors didn’t even spin any faster past 10% throttle :grimacing: there must be some sort of issue with power delivery from any batteries less than 6S.

As a last resort, I have ordered one of these USB programming devices (the BLHeli beep sequences seem to be different for every ESC, so programming via the transmitter was pretty much useless)

FVT Program Card USB Link


Once I receive this part I will continue my tests, including trying out higher timing, motor gain etc. and share the results. Or maybe I should just go full 6S?