Tx throttle has only on/off control, no proportional control


#1

With Arducopter APM 2.6 I got to the point where ESC’s are calibrated and the Motor Test in MP works fine. But when I arm the system with my transmitter, the transmitter can only turn the motors on at some constant speed, or turn them off. There is no proportional control.
Has anyone seen such a condition? What could be the problem?


#2

If you go to the radio calibration screen to you see the channels move according to the sticks on your radio?


#3

Yes, all sticks look OK on the RC calibration.


#4

Ok and what flight mode are you in? Once armed in stabilise mode you should be able to control throttle directly. If you are in another mode such as alt hold or loiter then APM will control your throttle so your stick movement will not directly correspond to your motors.


#5

I’m in Stabilize mode, Alex.
Before I do anything else I’d like to know which power setup is preferable:

  1. A Ubec connected to the FC output and a jumper across JP1, or
  2. A power module, no Ubec, and no jumper?

#6

For a copter platform A power module, no Ubec, and no jumper would be best


#7

strong text Hello, hi flyer hr. Go back and recalculate on the set up. Go thru the wizard again. I found the same problem and also disarm the Failsafe in set up. This should help. U may have to reboot the APM board and start over…
Good Luck and Good Safe Flying
EdK/hi flyer


#8

hiflyer, how do I reboot the board? By downloading the firmware?


#9

GM Jacob7. I’m old timer, age 73 and been in R/C a long time. Last year 4/5=
yrs, into drones. All the way up to 700=C2=A0series and have a build in pr=
ogress now.=C2=A0 I’ve encountered many problems with the APM Board. Best r=
ead all you can on WiKi and the sites. U will learn much.I disconnected all=
my wires, hooked up the lipo battery and hit the reset button as I powered=
the board on. Or, Try holding the reset button down and plug in the batter=
y and all should hold steady on the light. Let go of the reset button.=C2=
=A0 You may have to take the jumper wire off P1, “Pin 1” to do this too?=C2=
=A0 One way or the other, it will work.=C2=A0 I have had two bad boards.=C2=
=A0 Gud Luck and research the sites for others have had similar problems an=
d don’t be afraid to ask questions.EdK/hi flyer


#10

hiflyer, you’re a youngster compared to me hehe.
I didn’t realize there was a reset button on the board. I’ll try your suggestion as soon as possible.
Thanks,
Dan


#11

hi djacob7,
I take it that you have set the mode of your transmitter correctly and that you have no trim set? Never use the trim options, trim should be zero in most cases. (see what modes other people use with your transmitter when flying quads)
As said, stabilize mode to begin (if in doubt set all modes to stabilise while testing, ignore such things as simple, super-simple etc while testing), start from scratch, re-install the device type X or +, quad etc, then re-test (no props).
Take it slow - remember this is an air frame, subject to hostile conditions, You’ve seen pilots doing pre-flight checks? They do it for a reason, check and double check :smile:

Totally agree with unmannedtechAlex et al regarding ubecs

And don’t do what I saw someone do yesterday - flying a “toy” quad on a beach with an offshore breeze. It was only going to go one way! He was okay at 6feet, once he ventured to 20’ good bye quad - splash!


#12

Hi Adrian,
Thanks for your suggestions.
I was a bit discouraged by the complexity of programming a quad so I’m taking a break for a while.
Will get back to it ASAP.

Dan