I get "Set param error..." while doing ESC calib in APM 2.6

apm

#1

While doing ESC calibration in Arducopter APM 2.6 I get a message saying "Set param error. Please ensure your version is AC3.3+"
Version of what is he talking about?


#2

You just need to load install arcucopter v3.3 onto your APM board. You can do this from the initial setup tab in mission planner.


#3

Got it. Thanks Alex!


#4

I have the same issue, “set param error. please ensure your version is ac3.3+” when I try to run the ESC calibration. I’ve installed the latest firmware as suggested above, but the error still continues. Any other ideas what might be causing that???


#5

I think it’s probably best to run a direct ESC calibration by connecting them directly to your receiver, or to use an ESC hub?


#6

UT, I think you’re right. I have done a direct calibration to the Emax 4into1 ESC, and the motors arm and work fine with the Emax ESC. But there has to be a reason why I’m getting that error in the Mission Planner when I try to calibrate the ESC’s. I’d sure like to find out why.


#7

I think the issue is that part of mission planner uses some things althat are not available on the firmware you have on your APM board. To be honest I have not used APM for over a year so can’t remember what the latest firmware version you can run on it.


#8

I just looked and I think AC v3.2.1 is the most recent firmware you can install on the APM 2.6 board. But if you want to upgrade to pixhawk just let me know and I can sell you a second hand board at a discount (if there are any available) if you want, just let me know and I will see what I can do


#9

Why is Pixhawk considered an upgrade?


#10

The main reason is that pixhawk uses a more powerful processor and has more memory so it has a bunch of extra features in terms of the code running on it. The ardupilot code is something like 700000+ lines of code so that is why you can only use arducopter v3.2.1 on the APM 2.6… whereas the latest version is 3.3.3.


#11

OK, now that’s become more clear. When I updated the firmware it said downloading 3.3.3, but on the flight data page (at the bottom) it said 3.2.1. (See attached pic)
Alex, I’m now able to arm the motors, but the throttle control is either on or off. When I push up the throttle stick on my Tx, the motors turn on and reach a constant speed, but there’s no proportional control. What could be the reason for that?


#12

Actually, I have tried several versions of the firmware, including the very latest but still have that same error message when I try to calibrate the ESC with Mission Planner. To get around that, I’ve manually calibrated the ESC (Emax 4in1) directly attached to the receiver and it works just fine. However, going back to Mission Planner to calibrate the ESC still produces the same error message. But the motors will spin up when throttle is applied. But the latest firmware installation causes my motors to disarm if throttle isn’t applied withing 15 seconds. That’s really annoying. I’ve read that there’s a parameter called LANDING_DISARM_DELAY…or something like that that can be set to zero through the CLI…but there’s no CLI in the latest firmware and that parameter doesn’t show up in the advanced tuning parameter list. Using older firmware (AC3.3.1) with my manual ESC calibration, I can get the motors to stay armed.

I just don’t understand why I get that param error message when using all the latest firmware and if I ignore it, how can I stop that automatic disarming?

BTW,the controller is APM2.6. Does that make a difference?


#13

The issue is that the new ESC calibration process in mission planner is not compatible with APM 2.6 because you can’t install the latest firmware onto APM boards. That’s also the reason why there is no CLI on the APM anymore as there is not enough memory. You can however change the parameters by viewing the full parameter list on the config/tuning tab to disable the disarm timer if you want. But in my experience it’s easy enough to just to re-arm it as you don’t want it to accidentally turn motors on when you are about to disconnect the battery if you bump your r/c sticks.