Stingerbee HD Faulty Gyro

Order Number: 694324
Product Name: Newbeedrone Stingerbee Hd 3inch Kit With Gps - Elrs2.4g - Sku: Nb-Sbhd-No3-Elrs
Brand: NewBeeDrone
Upon taking my first flight, when hovering the drone keeping the throttle where it is every 5 or so seconds the motors would seem to ramp up in revs, causing lots of vibration/shaking. All props are secured in the right direction and tight, various forums suggest gyro issues but I’m new to the hobby so can’t be sure if anything. I ran the motors without props in betaflight and there didn’t appear to be any noticeable differences!
Tried both sets of props, ran the motors in betaflight no noticeable difference across the board. All spinning in the right direction, as I’m new to the hobby I posted on various forums, themes seem to be potential gyro issues.

In the video you can here the motors increase revs yet the throttle isn’t being moved by me

Legend for the above black box image

Thanks for providing this info, I have passed this onto our support engineer at the manufacturer, so we should have a solution for you in 1-2 days.

In the video, just so I understand, when you are hovering, the sudden twitches up are not from your throttle stick, and the quad is doing it on its own? And I assume you verified that this is not a bad signal/potentiometer on your radio causing the throttle channel to twitch?

If you can, it would help to send over the actual blackbox log file for us to take a look at :slight_smile:

Kind Regards

Alex

Unmanned Tech

Join our community at dronetrest.com, or on Discord.

Hi Alex,

Yeah the sudden twitches up are not from me moving the throttle, I didn’t check the signal from my radio, as I’m fairly new to the hobby.

Upon your reply I did plug the quad into betaflight and look at the radio channels and they are flickering, more so on the other stick and not so much in the throttle channel. I then went and tested it with another radio but the same flickering happens, I have flown other quads with my radio so not sure what that tells us!

I can’t attach files ending in .bbl here so will send it in the utech-chat on Discord.

Thanks,
Jordan

Thanks, I have updated the settings on this forum to allow .bbl files, but for completeness on this thread the log is attached here too.
btfl_023.bbl (2.0 MB)

Hi Alex,

Hoping to get this returned or resolved soon, any update? it’s just been sat on the bench for nearly two weeks now!

Thanks
Jordan

We have had a reply from NewBeeDrone now, could you please check this and let us know so we can get this resolved for you!

We have carefully reviewed the video you provided and suspect that the issue may be related to the gyroscope. To assist you in further troubleshooting, please follow these steps:

Enter Betaflight to calibrate the accelerometer. After calibration, go to the motor section, place the drone horizontally, and observe the RMS value in the upper right corner. Observe the value for 1 to 2 minutes to assess the condition of the gyroscope:

  • If the RMS value remains consistently below 1, indicating that the gyroscope is functioning normally, you may proceed to re-flash the firmware. I have attached the relevant document for your reference.
  • If the RMS value remains between 1 and 1.5, it may indicate that the gyroscope is being interfered with or damaged, and further investigation is needed.
  • If the RMS value remains consistently above 1.5, this could suggest a problem with the gyroscope.

We understand your concern for the drone’s performance and hope these suggestions will help you resolve the issue. Should you need any assistance during the troubleshooting process, please feel free to contact us at any time.

Hi,

Value stays under one increases as the motor temperature does, RMS value ranged from 0.5 to 0.73 up to 2 minutes. If it requires re-flashing any guides on this?

Sorry, this should of been included in the last message,

Please flash Betaflight 4.4.2 onto your quad, select the target as INFINITY_AIO_255 (Infinity AIO 255)

Then once done, you can use the text file below to load the CLI defaults for your stingerbee. This will reset everything to factory defaults, as based on your gyro it suggests that the gyro itself is not the cause of the issue.

BTFL_cli_STINGERBEE_HD_20240621_180701.txt (27.7 KB)

If you need some more help, just let us know.

@ResearcherBot can you get some guides and links on how to flash betaflight and load CLI defaults please

Hi,

I have done this and the issue is still very much there, I’m at the point where I’d like to return the product. I’d like to return the product as faulty can you send me a label to do so, thanks for the support very helpful good service, that said I would like a working product.

Thanks
Jordan

Sure thing, I will get an email sent to you with the return details tomorrow when I am back at work. However, to speed things up, could you send over the latest BBL log from the flight after the update so we can look into that in the meantime and we can also pass this onto NBD engineers who can suggest a solution.

I also had another look at your last log, there does not seem to be any massive issues with vibraitons, but yet the pitch gyro is picking up some motion and its not coming from your radio commands to cause this:

Then when looking at the quad in some more details it looks like maybe the FC is not mounted correctly anymore, as it would seem that one of the grommets are super crushed (on the left), while the other has slipped through a little on the right?

If you could please double check this, and make sure that all the grommets are secure, but not squashed like that, you may find this is the cause of the issue.

Hi thanks for the continued effort,

Sorted out the fc position image attached, since the reflash the black box doesn’t seem to be capturing data anymore, there was some error in some of the cli commands in that file mostly frysky related and others I’m not sure about. So not sure on how to get that going again, awaiting an email regarding return.

Thanks
Jordan

Hi

We are just waiting on confirmation from NBD, as they are now saying that the issue is just a config issue now, so that means once they can give us the correct CLI, and it is applied then it should resolve the issue without any need for return.

However if do not wish to troubleshoot anymore then you can always return it back to us, however just to point out, that as per our returns terms, if we find that the issue is just a matter of config/firmware issue then this is not covered under warranty and you may need to cover postage costs to get it back to you. If you would then like us to fully configure the drone and set it up, this is a charged for service. However if we do find that there is a hardware fault then this would be repaired/replaced under warranty.

An RMA email has now been sent in the meantime.

Hi,

Happy to keep going for another week, before giving in to the return to confirm it’s not hardware. Hopefully NBD reply asap, any ideas on how to get the blackbox logging again? From what I can work out I’m maybe missing something from the ports tab? In the configuration tab there is no blackbox slider, running get blackbox in the cli looks right to me.

When flashing there was no exact INFINITY_AIO_255 target, there was NBD_INFINITYAIO255 which I assume is the correct one?

Thanks,
Jordan