SOLVED Naze32 rev6 10dof possible overheat/telemetry problem


#1

Went out the last few days during this nice weather with the quad

For some strange reason I can fly with a 3s 1300 75c or my 4s 1800 45c for a whole discharge.
When I plug in whatever battery I didn’t use It will spin up and fly or cut out and not arm, then it will fly fine and occasionally stop for no reason
Tryed full power and off and back on when is in air no problems there
Checked the soldering no problem there either

The only thing I’ve done to it since the hot weather is enable telemetry on the naze enable soft serial to my x8r smartport as I’m using sbus to naze for my controls
Telemetry comes up fine no problems on my taranis

Quad few fine before the hot weather and the telemetry

Diatone silverblade
Emax rs2205 2300kv
Blheli lightning 30a esc
Naze32 rev6 10dof
PDB with bec
Frsky x8r 2.5ghz
FatShark cmos 700 cam
FatShark 25mw TX 5.8ghz

Thanks Perry


#2

Hey, I’m abit confused (maybe because it’s too early) about what’s not working, are you saying that when you plug in a battery it never wants to arm? Or when you plug in a battery sometimes it will arm, but then randomly disarm? Or does the motors cut out mid flight?


#3

It will arm and fly for one battery then when I change battery’s that’s when the quad will arm and fly and then lose power or not arm.
but if I unplug battery and plug back in wait for escs to be ready and Arm it sometimes it won’t arm sometimes it does and when it does it will take off and fly or just cut out

If that helps thanks perry


#4

Haha ok, is one battery 4s and the other 3s ? As it could be a failsafe issue due to different voltages


#5

Yeah one is 4s one is 3s and I haven’t set up no failsafe :astonished: lol if that’s the problem do I set up in cleanflight or on my taranis
Or am I completely wrong

Thanks perry


#6

Before I done the telemetry and the hot weather come the quad was fine.
Running the 4s then the 3s one after each other.

Hmm could it be down to the telemetry or possibly that I haven’t updated my naze with the latest cleanflight firmware

Thanks perry


#7

Turns out after testing and rechecking everything it was my xt60 connection so a little bend of the pins sorted a nice tight fit solved it a treat :sunglasses:

Thanks perry


#8

Happy to hear you figured it out. I just makes the solution on this topic incase anyone else has a similar issue :slight_smile: