Naze32 failsafe activates after arming [SOLVED]


#1

Dear All,

I have a problem with my Naze32 failsafe. When I arm my quad (I use a switch arming) the motors spin for 1 -2 secs and they stop and I see red led flashing. In Betaflight I see that the failsafe has been activated (red parachute icon).

I did the Minimum Length adjustment from 885 (where my throttle is when switching Tx off) to 895. Still I get the same behaviour.
I use Turnigy 9XR pro with Open Tx. I did not do any failsafe config in the Tx - I cannot find it there.

Has anyone any idea how can I fix that?


#2

Hi,
Check your battery voltage settings in failsafe, maybe they are set too high and it thinks the battery is low as soon as you spin the motors
Cheers
Steve :slightly_smiling_face:


#3

Hi Steve,

thanx for your reply. Unfortunatelly this does not work. Just a second ago I went to Power and Battery tab i BF and I disabled all voltage and current sensors (both to “None”) and the board still behaves same way - 2 secs of spinning and then … all motors stop.

Is there any way to check what is the reason for failsafe to trigger? Can I disable failsafe anyhow? Just for the sake of moving forward with the build?


#4

On betaflight near the connect button there is a slider for advanced mode… once you enable that you should now see a failsafe tab on the right where you can see/edit/disable the failsafe settings… If you cant find it, let me know so I can add a screenshot.

Its not a good idea to disable failsafe as this will prevent your quad from simply flying away…

Another thing to check is the failsafe throttle value… maybe your idle throttle is below the falsafe value… so as soon as you arm it thinks throttle value is too low to activates failsafe?


#5

Hi,

Alex, thanks for your reply.

Two days ago, inspired by Joshua Bardwell, I discovered that I had a wrong TX settings. The thing is that I use RangeX IRX4 2.4G CC2500 NRF24L01 A7105 CYRF6936 4 IN 1 Multiprotocol STM32 TX Module and bind it to Turnigy 9X 2.4GHz 8Ch Receiver (V2). I set the TX to Mode: Flysky; Subtype: V9x9 but for this RX it should be Mode: Flysky; Subtype: Std.
That solved the issue


#6

Great ! Glad you got it sorted :slight_smile:
Happy flying

Cheers
Steve :slight_smile: