New quad build trouble with getting it off the ground

Firstly, I need to get the elephant out of the room, I’m new to this hobby. Please read patiently the following, it’s from the heart :slight_smile:

My build includes:
F330 frame, Matek F405-STD FC, Matek PDB 6S, Matek VTX-HV, JHE B32 4in1 ESC, 4x Flash Hobby D2822 1450KV motors, 4x Gemfan 8045 Props and the FS-16X Transmitter and the accompanied receiver, FS-IA10B.

What I have done so far:
I have updated the firmware on the FC a couple of times as they keep on sending out updates.
It is built and, apart from the VTX, I have yet to receive the Video receiver which attaches to my phone, all seems to work, sort of?? In Betaflight anyway. I’m currently running BF Configurator v10.7.0
I have made up 2 battery packs, 4S & 6S, made up 3.7v 18650’s.

Config details:
Ports set to UART1 Serial RX for the Radio Receiver on I-Bus & UART4 Periverals VTX on (IRC Tramp).
ESC in ‘Configuration Menu’ set to ‘Multishot’. Not sure if this is correct, unable to discover the protocol required for my ESC. Also, ‘Receiver’ heading, set to ‘Serial based receiver…’ & ‘IBUS’.
‘Receiver’ menu option, FS-16X sticks work on default ‘AETR1234’ setting.
‘Motors’ menu option, motors all work in correct direction but only upto about 1200rpm. (see ‘Problems’ below)
Video (VTX) inserted the correct ‘VTX Table’ although I haven’t used them yet.

The problems:

  1. Betaflight seems to always display “Failed to close serial port” error message. Unrecoverable failure it complains about but seems to connect ok. Also, I get a message “Arming disabled”??
  2. When I connect the batteries they sometimes connect. If I connect them quickly they don’t connect but if I do it slowly I get a range ‘beeps’ and it’s connected ok, sort of?? In Betaflight the voltage displayed is as you would expect, spin the motors, using BF, and I can get a speed of just over 1200rpm but only if I do it very slowly. The displayed voltage now shows either NO volts or as much as 2v or 3v after it cuts-out. In an attempt to remedy this I have built a 2nd battery pack and replaced the XT60 plugs on the drone/quad. I have also removed the VTX as it runs extremely hot and wondered if this had something to do with it, it didn’t. I disconnected the Camera and the Condenser supplied with the 4in1 ESC, nothing works.
  3. If that wasn’t enough, I cannot run the motors using the FS-IA10B receiver. I have done the Binding and have a steady red light. I have also looked at almost all the full range of ‘Bardwell’ and ‘Dronemesh’ YouTube video’s, downloaded the 22 page manual, nothing works.

As you can see it’s all a bit of a mess and I am now desperate for some help. I hope there is someone out there willing & able to help.

Many thanks, Richard

  1. That “Failed to close serial port” message is normal, it’s not a sign of something going wrong, it’s most likely because you’re doing something conflicting with each other. “Arming disabled” is standard. It will disable you from arming the quad when its plugged into the pc and/or configurator.

  2. With the batteries it might just be a bad connection. The beeps mean its working, you should be getting five if all is correct. 18650 cells aren’t good for a lot of current delivery, you’d probably need an xs 2p pack for it to run. VTXs are designed to be cooled by the airflow around them, so its normal that they will get hot when just sitting around

  3. You most likely won’t be able to run them straight from the receiver, and on top of that, that would be a very good idea anyway.

Now to address the uncertainties in the “main” text: for that ESC to run well, u want dshot600, or 300 will do as well. The motors slowly spinning might be because of the wrong protocol, or as I said before, a weak battery

Thanks for your help, I have tried the other protocols you advised and more and the most I’m getting now is 1700rpm. The battery pack is 4S 15/16v & 4000mah. I cannot find any ‘xs 2p’ battery packs, maybe the ‘x’ indicates a number 2, 3, 4 etc?
Item ‘1’ If I have conflicting ports, is there a way of discovering what it could be with Betaflight or is there another tool I could use?
Your item ‘3’ says I won’t be able to run them from the receiver, I’m a bit confused here as I am attempting to run it from the transmitter, maybe it’s a typo or is it my naivety of the subject?
The VTX info is good to hear, I was thinking I’d cooked it.

Yes the “x” indicates whatever number of cells you want to use.
So for a 4s battery it would be 4s2p = 4 cells in Series, 2 cells in parallel, where the total number of cells would be 8.

If stuff is cnflicting, it just won’t save as a safety measure. This mostly occurs when setting up ports.

As to why you couldnt run the motors from the receiver, I should clarify what I meant: In the snese to fly the drone just from the motors hooked up to the PWM output from the receiver, that won’t work. But just to see if they can spin faster that way, if you hook it up properly, it should work

VTX or Camera problem or both :
I have striped it down and built it again, better this time, paying attention too the quality of soldered joints and board positioning on the frame. I have also decided to move from the 4in1 ESC I had to the, more conventional, one on each arm method (they haven’t arrived yet).

The problem now is the lack of video output. I have a Matek VTX-HV, Runcam Eagle 3 camera & Eachine 5.8ghz receiver (ROTG02). My only compatable UVC Android device displays a snowy screen but no meaningful camera image. Both the VTX & Camera are running extremely hot. I have put a small heart sink on the VTX.

I am stuck not knowing which way to go without some testing method that helps pinpoint which, if any, unit is going wrong. I have watched endless videos, done much testing for continuity/voltages etc. nothing!!

I can send pictures, Betaflight configs etc if someone wants to work through this with me.

Where’s Joshua when you need him? - :slight_smile:

Do you at least see any OSD?

Only the “snow screen” as described (like your TV with no signal). No defining image at all.

Get BlueMail for Android

You could try hooking up the video from the camera straight into the vtx

That works!! which proves the camera & VTX are working. They still get hot though but I suppose once it’s flying around the air flow will keep it reasonable.

The next problem is why it goes wrong when built up with the rest.

I copied the Matek wiring to their picture, see attached. TX4, Uart4 setting in BF was set to IRC Tramp. I can only think I missed some settings somewhere.

Get BlueMail for Android

I have a working camera now, I have moved the yellow wires from the FC, they went to the ‘cam’ & ‘VTX’ pads, and joined them directly. The result is NO OSD info, nothing. Not surprised really as there is no connection with the FC unless the TX pad on the VTX to TX4 pad on the FC connection is the data route. BF Port setting reflects ‘IRC Tramp’ on TX4.
I have attached 1cm heatsinks to the ‘VTX’ & ‘Camera’ in an attempt to reduce the heat produced.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.