Quad twitching violently during flight after new motors

betaflight
motor

#1

Just fitted the new T motor f40iii to my quad its the only part i’ve changed and now it twitches during flight particularly when you punch the throttle from low its clearly FC related maybe vibrations, FC is soft mounted but motors are not.

Anyone got any ideas?

ps the twitches are enough to not be able to fly it, they really throw the quad off

thanks
Alex


#2

oh and also my motors would be slightly warm even from a 1 minute test hover also i run stock betaflight pids


#3

What where your old motors?

My guess it’s it’s either p gain is too high, or your ESC timing is bad. Do your motorsake any funny sound?

What ESC are you using and are you using dshot, one shot etc…?

I also think your motors getting got is just because of the oscillations and should be fine once we find the cause


#4

Where you using the Same props?
Which one where the? Maybe there can handle more power / Thrust… (Too soft)
Other thing:
Soft mountIng ist a ideal. … as u sad


#5

Are your Motor screws too long?
The can heat the motor very fast up…


#6

running dshot on littlebees so timing should be ok no? have my min and max throttles set up correct on blheli

motors sound fine when not oscillating

I have noticed now that my 3d model on BF won’t stay still and rotates right yaw 5 degrees every 1 minute

after youtubing the hell out of it, i might have a bad gyro


#7

yes same props and also tried my mates race craft 5050s and it done the same

motor screws seem fine we all looked at them and all agreed they were ok


#8

on the day i turned my pids right down P gain was at 20 and it still did it, jus less violent


#9

If have only Seen this Problem once before, on a rc Helicopter :smile: IT crashed after a few Moments :smile: Maybe Blackbox loggIng could give a solution… (I Dont know anything about Blackbox, so this could be wrong…) Do you think its a Hardware or Software Problem?


#10

yea i done a bit of blackbox was very confusing but yea i think hardware problem, i actually ordered the new matek f4 board, was only £23


#11

I Dont know , if you under stand the following question but: does it Loks like, your quad does this , because something is broKen, or does it Looks like, your quad "tries to tel you something " (that it is a movement, that looks programmde. …) Sorry for my Bad language… Im german :frowning:


#12

looks like something broken is causing the FC to send a signal spike to a motor causing it to twitch


#13

Did you put a little hot glue on the Spot where the Signal cable is soldered to the FC? I Do this myself , that my cable dont go off, or anything like you have…


#14

no but i have solid solder points


#15

Did you Check the esc settings? Maybe the are still Set in the old motors, so the settings dont fit… :confused:
Which FC are you using?


#16

FC is the lux v2, the settings should be the same as im running dshot so the only thing you really have to set is the min and max throttle


#17

Which Radio are you using?
Maybe, i have an idea…
My Quad in my simulator is dong the Same, if the Signal es fettig verchromt Bad. … Maybe, the Software Has some issues… I Dont think, there is a Problem with the motors… Try to calibrate your accelerometer also…


#18

Are all motors running the Right way?
Pls try this also: https://youtu.be/HSUXSptR9gA
I hope its the Right video…
If this does not work, please make a video of the Problem. … So “we” can have a better look :slight_smile:

Edit: Ive just read that it is possible that your escs arent in synchro…