One motors spinning faster than the others


#1

Hello

I’m having some problems with one of my motors - it’s spinning faster than all others.
This is what I get in CleanFlight

If I use the handle from CF to test the motors, then everything works great - all motors are at the same level.
But if I use my transmitter - FS i6X, then I get this:


I’ve tried to calibrate the motors by taking the handle to maximum and then taking it to minimum. But no luck

Does anyone know why this is happening?


#2

Hi
Lt’s re-check your method of calibrating the ESC’s.

Connect controller to CF, with the motor page working (as you have shown in your post)
Disconnect LiPo battery, the FC stays powered by the USB connection to laptop/CF
Push master slider all the way to the top and keep it there
Connect LiPo battery
Listen for the tunes and wait till they have finished
Bring master slide all the way to the bottom and keep it there
Listen for the next set of ‘tunes’ and wait they end
Disconnect LiPo
Make sure master slider is at the bottom
Connect LiPo battery again and you should now be OK with all motors running at the same speed.

If not then you need to suspect a faulty ESC, swap it’s connections with another and see if problem moves to a different number.
If it does, change the ESC,
If it does not, swap motor with another,
If problem still there then suspect the FC but I doubt you will need to get this far :grin:

HTH, let us know how you get on
Steve :slight_smile:


#3

Hi Steve

Thank you for this!
I already did the calibration that way. Also did a calibration on the accelerometer. But it was the same.

Today I discovered the problem - kind of.
If I simply arm it, then I can see only one motor spinning faster - what I had in that picture.
I had the BLHeli ESCs and I’ve also tried to use the BLHeli suite program to flash the ESCs. But still no luck.

If I arm it and I activate the Horizon or Angle mode, then everything works well. I even took it out today in the open field to see how it works. It works really well!


#4

I have another question though about the throttle. Maybe you could help me as well?
I’ve created a topic here:


#5

Hi
You can use the EXPO feature to solve this
It can be set in either your transmitter or CF
Plenty of YouTube videos about that explain it better than I can
Cheers
Steve :grinning:


#6

Perhaps you guys can help me too… I’m having the inverse of the original problem. When I increase the throttle, 3 motors spin up but the fourth (top right) does not spin till about a third of the way through the throw. I have to set my arming speed to about 1300 for it to come on at arming. At that speed the quad will not quite stay on the ground.

This is what I’ve tried:

  1. Trims are all at 0 on controller
  2. Monitor shows correct output on controller/Cleanflight is the same
  3. Swapping RX – no change
  4. Swapping Controller – no change
  5. Swapping FC – no change
  6. Swapping PDB – no change
  7. Swapping PDB and FC together – no change
  8. Swapping ESC – no change
  9. Swapping black motor cables(esc cables still in correct position on FC) - problem changes to new motor – this would seem to indicate it is not a motor problem
  10. Changing position of esc cables (black motor cables in correct position) – no change

I did try to calibrate the esc’s but did not get the tune that is described in tutorials.

I would really appreciate any help on this.


#7

Hi
I think you need to concentrate on ESC calibration.
What you are descibing is classic ‘non-calibration’ and your lack of correct tunes would tend to confirm this.
How are you attempting to calibrate?
The good old method of connecting each ESC directly to throttle channel on receiver still works :slight_smile:
YouTube videos abound for this but come back if unsure
Cheers
Steve :slight_smile:


#8

Thanks Steve for the reply. I’ll keep trying to calibrate the ESC’s then.


#9

I guess it was the esc calibration. A guy at HobbyTown told me they were not synced up. I ended up having to take off the working three and calibrate the bad one by itself. Now its working. Thanks for the help.

Cody