Pixhawk Mini Autopilot / Taranis / X4RSB help pls!


#1

Hi all, any help with this would be really appreciated

I am able to bind my taranis X9d+ and X4R-SB however when i then power on the two to calibrate the radio, I get a green light on the X4R-SB and good signal for a couple of seconds and then the green light on the X4R-SB goes out. I can see the signal dropping to zero within those 2 or 3 seconds. QGroundControl gives me an error ’ Manual Control Lost’ as this

The exact same receiver and transmitter work on a different drone setup perfectly.

I’ve tried:
Upgrading the firmware on the X4R-SB
Reflashing the firmware on the Pixfalcon to latest PX4 via QGroundControl
Powering the pixfalcon via USB and battery/PCB power cable has the same result
Tried with all / none of the GPS / Telemetry etc connected
Tried both SBUS and CPPM channels

I feel I’m probably missing something obvious. Can anyone help?


#2

May there be a Problem with your RX or TX antenna?


#3

Hi Luca, thanks for your reply. I don’t think that is an issue because I have moved the exact same hardware to another drone which works fine. Also I’ve tried a different X4RSB and it reproduces the same result.

I don’t think it’s a power issue either because the X4RSB flashes red constantly, I’ve left it for a few minutes, until I turn on the Taranis at which point it establishes a connection gives a green light then signal drops after a few moments.

I thought it might be that i was too close and may be swamping the receiver however it’s the same from a few metres away.

Perhaps it might be the Pixhawk Mini doesn’t like the receiver but i can’t see why.


#4

Hey Steve,

To be honest i dont know why it doesnt work…
Maybe try if your Radio is working on other Drones so we can say that its not the Radio…
Maybe double check your soldering (if you did)
And double check your settings on your FC…

Luca :slight_smile:


#5

Thanks for your responses. So I deleted all models from my taranis, started again and all works OK, so must have been a silly mistake with the radio


#6

Happens sometimes :expressionless:
Glad your Gear is working again…

Luca :slight_smile:


#7