PX4 QGroundControl Telemetry issues

pixhawk

#1

I’m using a Umanned Tech Pixhawk running PX4 1.4.2 stable release in conjunction with QGC 3.0, with telemetry via xbee wifi link as for my purposes I need short range. However, I am experiencing dropped connections, and QGC is continuously unable to retrieve parameters via the telemetry connection. Xbees are correctly configured via the XCTU software and is connected to pixahwk via telem1. QGC is running on Mac El Capitan native, or on Ubuntu via a parallels VM. same issue experienced in both setups. No issues if connected via USB.

Is anyone able to point me in the direction of how to solve this?


#2

I don’t have an exact solution, but here are a few things to check.

First have your tried with different baud rates? I know some xbee modules encrypt the connection which takes abit longer so running on a lower baudrate might improve things. Just remember to set the telemetry baud rate to be the same on the pixhawk

Also you can possibly try running a range check on your xbee modules via xctu software. But I can’t bee too much help as the last time I played with an xbee module was about 3 years ago so can’t really remember.

Let me know how you get on so we can figure this out


#3

Hi Alex,
Thanks for your reply. I appear to have solved this by upgrading the firmware to 1.4.4 (latest stable version) and switching to using a non OS X based machine. Seem to have stabilised for the time being. Also have found some channel interference in the area so switching channels has also helped.