Need help with helio spring fc


#1

I have a Helio spring fc and it is giving me problems. At first, when I armed the quad in angle mode to test hover the quad motors would spin even though I set motors to not spin when armed. After that I tried powering on the quad but the last 2 startup beeps didn’t sound so the esc’s were not getting a signal from the fc. I checked and there aren’t any shorts on the board. The vtx and rx light up and work. I’m hoping someone can help me on this.

I am using:
Helio spring fc
Anniversary Special Edition Racerstar REV35 35A BLheli_S 3-6S 4 In 1 ESC
Emax ls2207 2400kv motors
Matek vtx
Fli14+ reciever
Micro eagle
Flosstyle frame


#2

The missing Beeps at the end do not mean that the esc dont get signal from the Fc it means that the Throttle Signal was not detected.

This explains why your Motors are running without you wanting them to spin…
Try to recalibrate your Escs and double check if you set everything up correctly in the Esc/Motor Configuration Part in the Configuration Tab.

If this doesnt work double check that you can see in BF the Throttle Bar moving, when you move your Throttle Stick.


#3

I just recalibrated and I’m still not hearing the last 2 beeps. Everything is set up correctly in the esc/motor tab and the throttle bar is moving in BF.

I’m not sure if this information would be useful but I reversed directions of my motors and reassigned motors and fc direction in betaflight. I was able to make it hover and after I landed I was not able to hear the last 2 beeps. Also something sounded wrong from the start because the last 2 beeps sounded a bit more delayed than usual.


#4

I’ve sorted out the problem now it’s because I was running 32k in dshot600 but dshot600 is incompatible at 32k.


#5

@Jason_He

I didn’t know that… Thanks for you sharing.
Do you have a link to were you found that information. I would’t mind reading it and bookmark the link for future reference.

Thanks


#6

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.