First Build Question: What could cause all 4 of my ESCs to suddenly stop working?


I’m working on my first Quadcopter build, and after finishing the soldering portion and attaching a 4S battery, I got the (1-2-3) startup beeps on my BLHeli_32 ESCs.

I’ve tried a few times sucessfully, but after a little bit the beeps stopped happening when I plug in the battery. I don’t recall making any drastic changes…

My flight controller still seems to work fine, it talks to Betaflight Configurator seemingly OK. I have gotten the receiver to work and receive information in Betaflight as well.

I have installed BLHeliSuite, but it cannot find any ESCs.

Is there any way I could have somehow fried all 4 ESCs simultaneously? Or are the ESCs waiting for some sort of signal that I don’t know of? The ESCs arent blinking or making any noise whatsoever…

Relevant parts:

Flight Controller: Matek F722-SE

ESCs: Racerstar Tattoo+ 52A

1st thing i would check is make sure your throttle is 100% lower that 1000us in betaflight when armed

I don’t think you have killed all 4 ESCs as that would be extremely bad luck…

@dale589 is on the right track I think…
If ESC’s see a throttle signal high enough during power up they go into a calibration mode.

So a couple of things to try…
In betafight set the motor protocol to dshot600 ( save and reboot )
remove props
download and use BLHeliSuite32 not 16
and see if you can detect your ESCs
You may need to plug in a lipo and connect then read configuration ( or something close to that )
if you can untick “program of Tx” (its near the top… I think)
Save your settings and unplug the lipo

See if that works
also make sure your throttle moves from 1000 to 2000 in the receiver tab and min
your ‘stick low’ threshold should be higher than the low throttle… so

My channel goes from 1000 - 2000
My ‘stick low’ threshold is 1010

Give that a go and let us know how you get on…

Hi, thanks for the responses!

I had been using dshot300 for testing earlier, but changing to dshot600 made no difference.

I have been using BLHeliSuite32, here is the message I get when trying to ‘Read Setup’ or ‘Check’ inside BLHeliSuite32:

Where is ‘Program of Tx’ found, and what does it do? I was not able to locate it when I searched around…

Here are screenshots for throttle low and throttle high:

Low (throttle is in this position upon startup):


The thing that I should mention is that I used to get the (1-2-3) beeps when plugging in the LiPo battery, but I do not get these anymore.

I have had all four ESC to stop beeping a few times. To fix them I went back to betaflight or cleanflight and calibrate all four ESC over again and it fix them. Gave me a really sinking feeling each time it happen thinking they fried each time and calibration fixed them each time. Also each time it happen, I was working on drone adding something or fixing something on drone. Hope this helps and your fix is as easy as mine???

Sorry I was wrong… untick Throttle Cal Enable

I tried this, but it doesn’t seem to make a difference. When I click ‘check’ or ‘read setup’ the checkbox gets re-ticked again.

What exactly do you mean by calibrating the ESCs from Betaflight? Just setting the throttle to max and min from the motor tab?

Reset the esc’s, try BLHeli confugurator
Flash it corrupt esc inbulit software

@CJB did you figure this out? I think I ran into a really similar problem. It was really strange. One minute the ESCs are beeping at start up, then I go into the Betaflight CLI to remap the motors and after a couple of resets, the ESCs aren’t beeping anymore.

I reflashed the FC, I’ve reset Betaflight settings, I can’t get BLHeliSuite or Configurator to recognize the ESCs. On the motor screen of Betaflight, the signals are all flatlined.

What the heck could have happened? My quad was 20 minutes of computer fiddling away from being airborn and now it doesn’t have ESCs.

@drox from the sounds of it maybe you remapped the ESC outputs on the FC incorrectly which is why the FC isn’t sending signals to the ESC anymore (and probably explains why you can’t see them in blheli config.

My suggestion would be to reflash your FC but make sure to tick the full chip erase option as that will fully wipe anything before flashing. Also make sure you are using the right target when flashing.

Otherwise try the other basics like making sure everything is connected correctly, and everything is powered (you need to plug in battery when testing esc, as usb can’t power them) etc…

Hope that helps :grin:

@drox Sorry, guess I didn’t post an update here like I should have.

I ended up buying a new (identical) flight controller and 4 new ESCs… I wasn’t making headway with troubleshooting and was getting frustrated. Haven’t had any issues with the new parts. At this point I think I just caused an electrical short at some point during final adjustments, causing damage to the FC or the ESCs.

It could still be something else, but I just haven’t taken the time to see what it could be. Sorry that I can’t give solution you are looking for… ):

(Have you made any physical or soldering adjustments after having the ESCs beep to you?)