ESC BLHeli Suite won't connect

blheli

#1

I am using a diatone dlink f3 v2 flight controller with diatone oneshot 42 heli S Max 60A ESCs. My motors respond in betaflight when I use the slider. When I try connecting to BLheli suite only esc 3 reads. ESC 4 says erased or unknown firmware while esc 1 and esc 2 show three dashes. I also tried connecting using the chrome app blHeli configurator and only esc 3 shows up. My battery is connected and like I said in betaflight the motors spool up with the slider. They also spool up inside the blheli suite in the motor tab using the sliders.


#2

Update: After disconnecting from blheli suite and back into betaflight I get no response from motors.


#3

3 days ago i had exactly the same thing happen to me with DYS 30a escs, i assumed i had bought dodgy escs, after fighting with trying to flash them and it sometimes working somtimes not i was left with one esc working and 3 with the dashes next to them as u spoke of (i think that means there not visible to blheli) i connected and old littlebee esc and it worked fine with blheli, so i jus assumed the esc brand was crap

That version of blheli AH30 thats the version i was using as stated by blheli for the DYS, u sure its the right version for yours?

I’ve now ordered 4 new littlebee dshots, i should of done that in the first place


#4

Yes they are AH30. I actually read that there was a change to the newer betaflight firmware. After version 3.0.1 there was a code change that disabled passthrough from the flight controller. I downgraded to version 3.0.1 and now am able to see esc 1 and 2. I ordered two more escs thinking I might have bricked esc 3 and 4. I hope thats the case as pnce I replace the two I will see all 4. If I’’ still having problems I might have to resort to buying 4 new ones like you did.


#5

Hi guys, did anyone end up figuring out what the problem was? This just happened too me also with AH-30 and the same ESC… I’m totally guttered my drone is brand new and I was told to do it by the shop owner.
Now I got no escs except for on …
there was 2 showing up nop. 3 and 4 … I diconected and reconnected and it showed two again this time 1 and 3… I tried discon and recon again and it only showed up no 1… I went out and connected to betaflight and motors tap and no motors bvut the one showing in the bl heli config would spool up…
This was flying and all motors working prior to connecting to BLhelis… I have diatone tyrant s215 dlink F3 and diatome MAX60a 302X oneshot 42 heli s… when I read from the bl heli app it reads escs as AH-30 16.2 was going to flash firmware to latest but now I have a 300 dollar piece of carbon fibre…
please help

thanks in advance

Help please


#6

There is a bug with beta-flight that sometimes if you update FC firmware with ESC connected it can cause them to brick, which is possibly what happened in this case.

Another other possible cause is that there is not a good connection between teh FC and your ESC’s,


#7

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.