First build problems with dys xsd30a v2 esc


#1

I have a pixhawk with the xsd30 esc;s during setup all goes well until when in BLheli suit I try to connect to the esc’s using the passthrough option and it wont connect, I get a window saying to check power and usb connections.After some research I learnt that there are some some bootloader issues with blheli esc’s so I bought a usb linker to connect directly and still no luck. The log reports “boot info wrong” So where to from here, is there a way to make them work,
thanks


#2

You need to connect your battery to power the ESC to connect to blhelisuite. But those ESC use the silabs MCU so hsould be fine to work with blheli


#3

I do have the battery connected. Without the battery it just wont connect as you say.
From the “boot info wrong” message reported in the log it appears that boot loader is incorrect for whatever reason but I’m only guessing. I have 8 of these so I’d to get them going.

Thanks


#4

Can you link your linker and send in some connection pictures and screenshots.

Screenshot and pictures can make all the difference


#5

Here is the log sreenshot


#6

your using the wrong version of BLHeli
BLHeli32 is for 32bit ESCs

you need BLHeli 16


#7

#8

I knew it was an easy fix that’s why I couldn’t find it. That works fine with the linker it connects straight up no problems.
I was hoping that would explain why passthrough doesn’t work with the Pixhawk 4 V2.4.8 as well . Blheli see’s the FCU on com 3 ok and I tried both atmel and silabs interface options but it just times out saying to “check port and power connections”
Thanks for your help.


#9

When flashing all 4 ESC through your FC you need this option.

image


#10

I went to using the linker because I could’nt get passthrough to work after reading the guides and watching videos and now using BLheli 16 it still does’nt work.
This came about after going through initial setup in mission planer and all went well ,radio cal, esc cal etc then went to test run the motors and no response from the motors until the throttle was at about 25% then they only revved to about 10-15% , increasing the throttle makes no difference to RPM. Then with throttle shut off they continue to run for 3-5 secs.
So I confirmed the esc firmware is about 16.2 it’s not old and I haven’t tried updating yet.
When looking at servo output in MP the ch3 throttle scale moves proportionally and smoothly to throttle position as expected.
So this led me to believe there was a esc problem which is basically what started this tread.
And I’m still stuck in the same situation. Could this be an incompatibility problem between the pixhawk and these esc’s.


#11

Solved, setting the “Low RPM Power Protect” to “Off” in esc setup.


#12

Thanks for sharing the solution!..

For anyone else in the same situation, ehre is some more info on the low RPM power protect option from the BLheli manual:

Power limiting for low RPMs can be enabled or disabled. Disabling it can be necessary in order to achieve full power on some low kV motors running on a low supply voltage. However, disabling it increases the risk of sync loss, with the possibility of toasting motor or ESC


#13

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.