Kakute F4 AIO with Chaos 20A escs

blheli
kakute

#1

Hey guys,

just finished my new build.

Flashed the newest stable blheli firmware (16.61 dshot commands).
Flashed the newest betaflight, 3.2 rc3, and tried to spin up the motors on dshot600.
Strange things happened:
In the motors tab, I can spin up the motors sperately and together without problems.
The moment I arm the quad, sometime motor 1 starts spinning and the other 3 dont, sometimes the other way round.

After disarm, I cannot spin them in the motors tab anymore.

So, flashed bf3.2rc2, bf3.2 from the kakute homepage and bf3.1.7.
Last 2 Versions are working, but these versions have some not included features I would like to use, so that was no option.
Flashed back to blheli V16 and now it works. But no dshot commands, which is sad.

So, it looks like the dshot commands freeze the esc.
Can you confirm this at any point?

Greetings
Nico


#2

I am just abit confused if you are having issues with latest kakute firmware, or the latest BLheli_s firmware?

I cant rember off hand what version Blheli the chaos ESC are shipped with, but it should be one of the latest blheli versions and I have had no real issues with Dshot commands.


#3

Ok, I thought this was clear, sorry.

I am not sure what the problem is here, but I guess its the esc firmware or the esc itself.

I have another Kakute on BF3.2RC3 with Emax Bullet escs on blheli_s with dshot commands.
They work well.

The chaos escs on 16.61 (with dshot commands) have the described issue. (freezing on arm, reboot neccessary)
On V16 they don’t have the freezing problem, but they do not have dshot commands neither, which I would really like to use.

So, what to do now?


#4

I am going to check this issue with the ESC desginer to see if they know if there are any issues with firmware or if this is just a strange issue with your ESC as you said it seems to happen on motor 1 or 3. I will get back to you as soon as I have an answer for you.


#6

Well, it was really strange.

Before I armed all motors were working when I turned them up on the motors tab.

After arming the quad, it was very strange.

Arm -> nothing happened -> disarm and wait 2 seconds, arm again -> motor 1 starts to spin -> disarm, wait, arm -> motor 2.3.4 start to spin -> disarm and test on the motor tab and no motor was working. Disconnect the power and reconnect and all motors work again spinning them up in the motor tab, arming the quad leads to the same thing again.


#7

Do you have any news on this topic? Its been a while since your last reply, Alex.

Greetings


#8

Hi, apologies about the delays in getting back to you. I have been talking with the designer of the ESC and trouble shooting with them so we should have a solution soon. Either way we will either figure out the issue and if needed will replace the ESC.


#9

Just another update is we have been talking with our ESC designer who has in turn been talking with one of the BLheli developers and we cant seem to figure out why this is not working… Could you try with blheli firmware 16.63 to see if that has the same issues?


#10

Ah, ok, there is a new version. I will try that later.


#11

I had a similar issue with the latest blheli dshot firmware on 30a chaos escs and with same board as you ! Motors would sometimes arm then not and sounded really odd! Flashed them back too 16 something will check later and working fine on 3.2 rc4 dshot 600