My pc wont recognize my drone

betaflight
zadig
drivers

#1

Hello everyone,
I have recently purchased the geprc sparrow,
I tried to flash it with betaflight but after the flash, my pc won’t recognize the drone anymore but the betaflight do recognize something it connects to the drone but when I move the drone it looks like its stuck i tried to restart my pc, zadig, and impulserc but nothing helps.
I don’t know what to do, please help me.
thank you all for your help and time.
(in the pictures there is no battery conected)


image


#2

Have you tried switching to another USB Port or another Cable?
Try mixing around with USB 2.0 and 3.0…

The following idea is translated from german to english… im not sure if the english Windows calls it like that…
Settings -> Open the Device manager -> go to “Devices and Printer” (picture 1) -> right click on your FC -> click on "troubleshoot "

Sometimes only this step helps…
Also try different drivers…
I personally use this Driver… Works fine for me and never had any Problems…
(From Flyduino… and yes it works with non-kiss hardware too)

Picture 1 :


#3

It looks like after you flashed you board it is connected and working.

The reason the 3D model is not moving is the gyro is not active (look at the icons at the top)
You may have to go through your Betaflight settings.


#4

Hey, doomedfpv and thank you for the fast response.
the gyro and the accelerometer are enabled but it’s still not working.


#5

Hey, Luca and thank you for the fast response i tried your method and i didnt have any luck.
i dont really sure how to install the driver can you explane alittle bit more?


#6

Just click on the Link…it will start to download the driver automaticly… once you downloaded it, go to your "Downloads " Folder and start the setup.exe… (it is called a bit different) Once you started it its just a matter of clicking through…

Luca :slight_smile:


#7

Another issue that could.of happened, is that when you flashed the firmware ,you selected the wrong one, as each flight controller has its own firmware. So I suspect maybe the one you flashed is for another FC that uses a different gyro so that is why it isn’t detecting it on your pc anymore.

I assume it was all working before you flashed it? In my experience Geprc are a decent manufacturer who don’t have many issues, but when they do they do fix it. I can’t recall off the top of my head what FC the sparrow uses, but should tell you in the manual.


#8

PBF3 - EVO F3 Flight Controller
Is the board.
I think that you are right about the issue
But can I fix it ?
Or it’s permanent?


#9

You can re-flash the FC normally.

Puting wrong Firmware on doesn’t normally brick a FC any more.


#10

Oh and I forgot to tell you something,
My drone’s led don’t light anymore after the flash.


#11

That is not a good sign,is this the led on the flight controller, of the ones at the back?

If its the ones at the back it’s likely a firmware issue that can be fixed as updates reset all the settings. If its the led on your FC then there may be a hardware problem :exploding_head:

My suggestion is reflash the firmware with a full chip erase


#12

There’s a green light for like half a second when I connect it


#13

thank you very much for all of you guys you really helped me.
it was the wrong beta flight flash.
now its working great.


#14