Motors not responding to controller, controller also not working fully on LibrePilot

librepilot
zmr250

#1

Hi Everyone.
I got myself the ZMR 250 kit with the Flysky FS-I6 controller, to teach me the basics of building a quadcopter.

I’ve built it all up, connected it to libre pilot and all the motors spin up! I then bind it with the transmitter, and that’s when it all falls apart. Librepilot can see that I am moving certain sticks, but it never shows it on the screen about checking the picture is mimicking real life. If I unplug it from the computer, it still doesn’t respond at all. Any ideas what could be wrong? I’ve double checked the cables going to the receiver and it looks ok to me. I’ve also hunted online but struggling to find anything similar (could just be a lack of knowledge of search terms though).

Thanks for any help!


#2

Hi I don’t know if you’ve figured it out yet but when your first going through the setup process librepilot will set your arm/disarm to always off for your safety. When your done with the setup then you can set what you want your arm/disarm to be ie:throttle all the way down and to the left. I wouldn’t call it lack of knowledge just that you haven’t learned it yet, it will eventually become second nature. cause trust me if your just starting off in this you’ll know librepilot like the back of your hand when it comes to pid tunning.


#3

Still nothing. Been all the way through, it still doesn’t respond. I’m wondering if there is an issue with something in the wiring with the receiver or something. Or if one of the components is faulty or something.


#4

Just as a test for arming set your arming sequence to always on and try it. Make sure all your props are removed, if it responds then your not making it the last thing you do on your setup. If you set it then go to motor page it will set it back to always off.(it’s a safety thing). And if you think it still a wiring problem then invest in a basic multimeter that has a continuity function to help check for shorts. Hope this helps.


#5

Tried that - still no response.

Checking the pcb tomorrow with a multimeter.

I’m not sure if it’s something to do with wiring all the cables from the flight control board into the receiver: given that everything spins up and works on the initial calibration I would have thought it was unlikely to be a short on the pcb.

I’ve attached a couple of pictures of the bits around the receiver and a couple of photos from libre pilot. As you see, there’s an acknowledgement from it that there is input into the channels, but it isn’t actually showing what the sticks are doing.

Uploading…