Mobula7 HD binding issue?


#1

Hi, Ive got Mobula7 HD with Tbs Tango and Frsky DJT RX and I couldnt bind this set together.
Change settings on Tango for D8,D16, flipped switches on the back of DJT, change modes in Betaflight and its not working still.
I tested on D8 all way and nothing, D16 the same.
Any advice will be appreciated.


#2

I know it’s not to do with binding but have you got the one with 9000kv motors & a cap on the xt30?

There’s 2 common failures that they have addressed since releasing

ESC - original had 10000kv motors, now has 9000kv motors

5v bec - caused by voltage spike, cap reduces spike


#3

I have only used the crazybee f4 controller with frsky X radios. But I think the DJT will still work with the internal SPI reciever, you just need to set it to D8 mode. Check the betaflight wiki for more information


#4

Ive got the latest Mobula7 HD with 9000kv motors, thanks for Unmannedtech.

I did set up TBS tango protocol for D8 but there is no difference.
FrSky DJT just beeping once in binding mode and there no other action.
Ive got advised that Mobula7 HD will only work with XJT module but there is no reference to it anywhere…


#5

Are you entering bind mode via the betaflight cli on your FC?


#6

I tried both ways, press the bind button on the board and CLI command “bind_rx_spi” in betaflight 4.0.
None of them worked.


#7

Are you sure you set your DJT to D8 mode? And that it is running the latest firmware?


#8

I cant check if DJT has the latest firmware.
Purchase XJT module and its on fire now.
Frustrated process however.