Jumper T12 Plus setup for Hubsan H501S


#1

Hi,
Can anyone point me in the right direction on how to setup a Jumper T12 Plus to work with my Hubsan H501s - Im new to using OpenTX having only had the stock Hubsan controller up till now. I have managed to setup a simulator model that works well and suddenly I can fly better! Im waiting for a Mobula7, but in the meantime I thought I would try to get hte Hubsan working.
Ive added the model, selected Multi - Hubsan and I think it binds (it stops bleeping), but I cant arm the quad (using down and out gimbal movement) - to be honest I dont know where to start and I cant find anything that works using Google searches.
Any suggestions gratefully accepted,
Chris


#2

@unmannedtech1
Any ideas ?


#3

I am really not that familiar with the H501S so I can’t be that much help :disappointed_relieved:. But one thing to check, assuming you are definitely bound to the quad is maybe the channels are reversed so it is not arming? They could also be mapped in the I correct order too. Can you connect to your hubsan somehow (via pc software or built in menu) to view the RC channels to see if it is correct or not?

Also make sure you remove props.before playing around with this as you do not want to accidentally active the motors to full throttle with the props on.


#4

have you not gone onto www.deviationtx.com
there you should find your request


#5

I’m not pro but some suggestions -
Are you sure it binded? May be turn on and off the radio and see of the receiver change light pattern?
Does it show the stick movements if using example betaflight?
Did you set up mixer in the Jumper? I was having problems and couldnt arm until I set up mixer (I have T12 too)


#6

Thanks BUGS2C I’ll take a look, I didn’t think of look there as I have OpenTX on the T12plus, but information is information and it might point me in the right direction.


#7

Thanks blackhole,
I’ll check the mixers, I definitely haven’t got the switches set the way you have them as I hadn’t found the channel mapping yet, so that’s a great help. Haven’t got my Hubsan with me at the moment so can’t check anything until after Christmas now :frowning: so will just have to get more practice in on FPVFreerider in the meantime!
Thanks
Chris