HUBSAN x4 501S will not calibrate gyro

hubsanx4

#1

Flew it twice. Fly’s perfect. Next battery and it errors on " Check Gyro Sens " , preventing the next step, set compass. There are alot of fflashware updates around and I have not uploaded a one. Battery indicator shows red, empty LiPo. SATs on QUAD and TX load up, video is up, steady short one second apart beeps… Rear LED flash red, from flah white/blue. Screenshot says manual mode
Any thoughts appreciated!
Scott


#2

Have you tried to go through the calibration process again? I am not super familiar with the hubsan X4 as I don’t own one, bit it should tell you how to do it somewhere in the manual :slight_smile:. Also when you power on the quadcopter, make sure it’s perfectly still to allow the sensors to initialise.
Otherwise if it’s still got any problems you might need to sent it back for replacement


#3

Thanks so much. I appreciate you responding!! I will give it a try. I have been practicing…attempting to practice, with a little proto x drone, in the house. Now if I can just get the dog to fetch when I crash…oh, and “POINT” when the props come off.

You must be flying awhile? I’ll go through the site to pick up tips to fly.

I did find out, and rather quickly, there is not much of a glide personality at all with these guys, right? Lol, off, Boom, drops like rock. Tilt to right??? Yup, all the way to the crash site. Ha!!

Thanks for the time you take to share Alex!

Scott


#4

Haha, my dog hates when I fly he tried to attack any miniquad I fly indoors, and if he catches one if i crash I have to chase him around the house to get it back! But would be super cool to tech your dog to play fetch with a micrquad!