Camera does not work on new Hubsan H501S x4

hubsan
multirotor

#1

Hi. Only flown the drone once. It flies excellently. No complaints at all except I cant get anything from the camera. I have inserted a brand new SD card (the right way) and tested the SD card in another camera. The card works fine.

The drone transmitter screen recognizes the SD card. FPV/ Camera view on the screen is fine. The screen camera functions all work as per manual i.e: photo and video buttons, and video recorder timer on screen all working. Also when you operate photo and video buttons, a blue light on the base of the drone comes on and goes off in conjunction with on/off operation of the buttons, which I hoped meant that the camera was working. Since the drone’s one and only flight, I have tried many times indoors to get the camera to work to no avail. If anyone has any advice, I will be most grateful.


#2

My suggestion would be try try reformat your sdcard to be fat32 as maybe the other camera you used changed something so that the hubsan drone can’t save to it? Do you know if it is at least class 10? Do you have any other SD cards to test with the drone?

It is abit strange because everything else suggests it should work. The last thing Incan suggest is to check the settings on the drone itself for things like video/image quality as maybe there is a bad setting there?

Sorry I can’t me more help, but let me know how you get on.


#3

Hi,

The information on the packaging that the new SD card came in says “Up to 98 MB/s** 653X” and at the top there is a figure 10 in a circle i.e: (10). I take it that means it is a class 10?

Not sure how to re format the card to be fat 32? Can I do this in the ordinary camera?

The drone doesn’t appear to be sophisticated enough to have different image/video quality settings. I will try another card. Thanks for help.


#4

I wish I could give you the answer but I have not had any direct experience with the hubsan H501S

Yes it does

I think you will need to use a PC for this

My guess is that it must be something on the SD card… but yet it works on other cameras…

Have you tried to contact the place you purchased it from? If they give you any hassles let me know and I can offer my ‘expert’ advice as we have been selling drones for a few years now and know all the tricks some shops try to use to blame the customer…


#5

Thanks Alex.

Here goes.

First off, Drone was purchased on Ebay and is now in the process of being returned. On to the camera.

After my last post, I bought another Sandisc SD mini card. Plugged it into the drone and shot some video. Took the card out of the drone and, this time, plugged it into Android Phone. Viola, I got some footage. So, I thought, problem solved, first card must have been defective. But not so. I took the card out of the drone, tried it directly in to the laptop, then the camera, and finally back into the phone again. Not only did it not work in all three devices, citing error, but also all three devices will not allow formatting. I give up.


#6

I have looked into this a bit more, especially about SD cards. Now, the appliances regarding the situation are

  1. Drone (brand new)
  2. Canon camera (at least 10 years old)
  3. Laptop (at least 10 years old)
  4. Android phone (new).

So, I bought a new Sandisc, class 10, 16GB SD card and plugged it into the drone. Took the Drone for a flight and took some video. Then plugged the card into the camera. Then connected the camera to the laptop. No footage.

Bought a second new Sandisc SD card (same class as above). Plugged it into the drone, went for a flight and took some video. This time I then plugged the card into the phone. I got some footage!
I then tried the same card in the camera and directly into the laptop. The camera gave a card error message, the laptop said the card required formatting but would not allow formatting (in any of the format systems). I them put the same card back in the phone and it now appears to be corrupted. The phone will now not permit the footage to be played and says the card requires formatting but will not format beyond 20%.

Having looked at various Youtube videos, I have come to the conclusion (I am no techie) that both the laptop and camera are too old to recognise the new SD cards and have possibly corrupted them so that the phone cant play them or, it appears, format them. Where do I go from here? Very grateful for any thoughts?


#7

(Is there really a best Micro SD card)

This guy did some testing (Only the first 8 minutes is relevant). What do you think?


#8

Sorry about the long delays in getting back to you… have you made any progress with this?

I have had similar issues with SD cards like this before, but found it is usualy just due to bad firmware that does not save things properly to the SD card. So if you turn off the device before pressing the stop record button, it will corrupt the SD card. So might be worth looking into that… When it happens to me I need to reformat the SD card before it will work again.

Your point about the PC/camera being too old to read the card might be true, but kind of unlikely, particularly for your computer if you have kept the software/drivers up to date in the last 2 years :stuck_out_tongue: But it could be the SD card reader/adapter causing a problem. .


#9

Hi,

Drone has been sent back for replacement (It had several issues, not just the sd card/camera).

I have done a bit of homework since my last post. You are definitely quite correct about turning off the device before stopping the recording. This apparently confounds the device and totally screws up the data transfer.

It appears that using the canon camera as the intermediary between the drone camera and the laptop was my downfall. (If I had plugged the card straight into the laptop, it would have been OK). The canon camera can only handle a 2GB card and I put in a 16GB that already had files written to it (from the drone camera). Result: Effectively the Canon camera said “'Im not having this” and corrupted the card. Lesson learned.


#10

You are definitely quite correct about turning off the device before stopping the recording.

Before anyone jumps on this, I obviously meant the other way round: i.e Stop the recording before turning off the device. Apologies all round.


#11

Happy to hear you made abit of progress, hopefully that was the cause of all the headaches, and if so sorry I didnt think of it earlier!