New drone flier - used Taranis X9D Plus totally baffling me

I’ve two new drones arriving from today from Unmanned Tech, and suspect I’ve messed up my firmware to the point that it won’t work with them. I already have a Supra7 Pro with an XM+ that won’t recognise my controller (EU model); it’s showing solid red and green lights which I understand from this forum means mismatched protocols.

In the model setups the only mode option is XJT (LR12, D8 and D16). I understand XJT to relate to an external RF add-on, which I don’t have. I believe this is a totally standards X9D Plus, pre-2019, EU LBT.

The SD card is the only way I can get firmware on to the controller because neither my Win10 laptop or Mac will run the USBs correctly!! OpenTX Companion has worked on a couple of rare occasions but mostly fails. My computes are failing to see the controller as external drives when turned on without boot loader. The radio does work as a game controller for my simulator on the Mac. I’m really not this much of a muppet usually.

So I think my questions/problems are:

  1. Have I applied irrelevant protocol in an incorrect firmware?
  2. Can I fix this without OpenTX Companion?
  3. Any idea how I’ve messed up OpenTX Companion on two computers?!

I’d really appreciate any help. I’ve been battling this for hours every day for over a week and I’m getting nowhere.

I don’t know what to say, but the same as intermittent faults fail to present when an expert is around, having finally reached out to those more knowledgable, I’m up and running with the right modes and connected to one of my new quads. The fix appeared to be downgrading the radio’s firmware (v2.2.4), remained on latest boot loader (v2.3.7).

OpenTX Companion is still beating me though. It worked for a while and then gave up on me again. My laptop has also ceased to recognise the radio as external storage when not in bootloader too. What a bore!

r u sure XJT is the only selection, u should be able to choose internal RF, aint never gona work if its on external RF and youve not got one fitted!

XJT had been showing as internal RF. I forgot that part of my fix was to (after random attempts) to get my Mac to recognise the radio as an external storage device long enough to delete the firmware and eeprom files from it (not the card but the actual radio). A reboot made it all work.

Thanks for your reply. :blush: