Getting FS-A8S Receiver working with Omnibus F4 v6 FC


In the process of trying to construct my first drone, mostly seems to have gone well. However I am currently unable to get any response from the remote control.

I am using an Omnibus F4 V6 flight controller and the FlySky FS-i6X Transmitter / FS-A8S Receiver combo.
It seems the V6 is quite new and I can find no mention of it beyond listing on various shop sites, however I did manage to get a copy of the pinout from unmanned techs support guys.

Currently I have the white wire connected to a pad on the FC labelled SBUS and the yellow connected to RX4. When I connect to the FC to usb the receiver starts flashing red and when I turn on the transmitter it becomes solid red which suggests they are paired, however despite trying various settings on the “configuration” and “port” pages in Betaflight I just don’t get any response from the transmitter when lookin on the “receiver” page.

Any one have any ideas?

(Here are the relavent sections from the manual)

First of all:
You need to choose if you want to use use SBUS, IBUS or PPM.
The Yellow wire is PPM and the white wire is SBUS.
I suggest you use SBUS because it is faster and simply better :smiley:
That means you only need to connect the White Cable to the Port labeled “SBUS”.

Do not forgot to choose “SBUS” and “Serial Based Receiver” in the configuration Tab and enable Serial RX in the Ports Tab (UART 1).

Thanks for the information, I have tried disconnecting the yellow cable in the hopes that having both was just causing confusion. Unfortunately with the settings you mentioned I still got no activty in the receiver tab, just for the heck of it I also tried toggling the serial rx on for each of the 6 ports in turn with the same result.

you got a link to the manual.

and a picture of your wiring?

Here is the manual.

Can’t get a picture of my wiring at the moment but here is an edited version of the above diagram showing what is connected where.

1 Like

The A8S has pinouts for PPM or IBUS, so just make sure you are using the correct one (IBUS) and that it is connected to the SBUS pad on the omnibus. The power and ground wires in your diagram are correct.


Once that is confirmed, the next thing would be to make sure you have bound your receiver to your radio correctly (this terrible video may help :blush: )

Then the last thing is to setup betaflight (serialRX on UART1, and set the receiver type to be IBUS) and you should be good to go. If IBUS is not working then try SBUS as I cant recall which one you actually need to use (and it also depends on the settings on your flysky I beleive)… I cant remember exactly as haven’t flown a flysky radio for a good 6 months now…

1 Like

I’ve tried both SBUS and IBUS but no difference. I was under the impression it they were delivered already bound but I have tried going through the steps anyway and I’m not sure I’m getting it right. The led on the receiver goes to solid red when both are turned on which it’s manual says indicates it’s bound. However that video and the images in the tx manual seem to be showing that when bound I should get both a TX and RX battery indicator on the rc screen but I only have a TX one?

Also which port would I need to connect the yellow wire to if want to give PPM mode a try just to test?

I think there is a setting on the flysky menus that let you enable sbus/ibus output on your reciever so I would try playing with that setting first. Otherwise ppm is usually on the same connector as sbus, but I don’t think this FC supports ppm anymore.

There is indeed an RX setup section on the flysky that has two toggle options one for pwm / ppm and the other for isus / sbus I have just tried this with every combination but still nothing.

Should I be considering alternative hardware at this point? If so which, a different FC or another receive? The latter would obviously be easier as would be a lot less connections to de-solder and re do. Would it have to be another FlySky receiver to be compatible with my transmitter?

In my case everything start working after reflashing betaflight on fc. I was struggling all day and after reflash and setup receiver in bf finally i was connected.

I have just flashed with the latest version (it initially had one dated from January) and now I only have UART 1, 3 and 6 listed under ports instead of 1, 2, 3, 4, 5 and 6. Tried on all three ports but still no response to anything under “receiver”.

That is strange. Did you choose correct fc target ? If yes probably is broken. Try remap one of uarts to camera pad and check if its work.

Ah, no I had selected just OMNIBUSF4 when needed to be OMNIBUSF4FW, I have now flashed with the newest correct version and all 6 UART ports are now back. Unfortunately my issue still remains as before, zero response from the receiver.

I’ll get some emails off to Airbot and FlySky and see if they can help but otherwise it looks like something is going to have to be replaced :frowning:

Not had any response as yet from either Airbot or FlySky so just picked up another receiver (the FS-IA6B) to try, unfortunately this didn’t come with any paperwork so I have no idea how to wire it up (didn’t come with any of them either apart from the bind plug) the IBUS label points to two different pins and there is nothing to show where to connect power to it :unamused:

Ok so I’ve now wired up the new receiver and as this one has telemetry I can confirm the binding as when I switch it on i get the RX battery indicater as well as a few other things on the controller display.

Unfortunately the problem still remains, dispite trying all available UART ports as the serial RX I still get absolutely no activity in the receiver tab of betaflight so either I’m missing a step somewhere or the FC is no good.

Can I just check the process should have gone as follows.

  1. Build the drone.
  2. Connect FC via USB
  3. Bind the RX and TX.
  4. In “BetaFlight > Ports” - Select Serial RX.
  5. in “BetaFlight > Configuration” - Select receiver type as IBUS / SBUS
  6. In “BetaFlight > Receiver” - Moving controls on transmitter should result in the colored lines and shown values going up / down accordingly?

OMG it’s alive.

Sooo, just found something saying you don’t want to be using the SBUS pad on the FC for FlySky receivers as the built in serial inverter apparently messes things up just moved the wire over to RX3 and boom, all is working, I assume the same would also be true for the original receiver but I can’t be bothered removing this one to try now.

Thanks all for the input.

1 Like

well done.
Glad you got it all working :slight_smile:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.