FC only opens in cli mode ( solved)


#1

Hi
Matek 405 mini and fchub 5
Have had the board connected successfully to betaflight several times previously. .
Have since soldered a few plugs and connected the fchub 5 ( fancy pdb).
Also soldered a ( old) ublox m8n to the suggested pads as per " inav flying wing " pics ( lower down on specs page ).
Now , when connecting to betaflight only cli tab appears. Should I disconnect gps ?


#2

strange that only the cli shows…

Can you link the image your following for the ublox
and screen shot BF


#3

This should be the hook up
https://www.unmannedtechshop.co.uk/product/matek-f405-mini-betaflight-flight-controller/
( inav flying wing )
Will take pic of pic screen , ( and try to work out how to add pics !) and add to next post


#4

There is a note saying " cli mode detected " when the cli page comes up on connection , and a pop up saying non betaflight boards not supported.


Look at that ! So excited at finding the add photo bit I added extra one of gps hook up.


#5

Well hooray , now connects and usual selection of tabs appear.
Tried flashing latest firmware but no joy.
Then did same with battery power as well as USB and that seems to have done the trick.
Possibly the old gps ( with its small fitted battery at 0.7v ) was draining power ?
Many thanks for your input mr doomed , it did inspire me to sort it !


#6

Just sat down to have a closer look at whats going on … and you have gone and fixed it already.

Good spot with adding the lipo power… maybe the FC + GPS was drawing to much power from your usb to get the FC to boot correctly.

Your laptop… USB1 or USB2 ports ?


#7

Oldish hp laptop so I presume older style usb1 ports ??
Gps on board battery now shows 2.5v by itself after having left it connected to fc & lipo for an evening.
Will soon be migrating to inav for this build ( flying wing ) so quite possibly more battles between my brain and gui. :blush:
Thanks for your attentions , knowing there’s somebody else on the case de-stresses the situation in some way. :+1:


closed #8

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.