Matek F722 + Betaflight


#1

Hey all, Can you guys tell me how to connect Matek f722 to betaflight? I pressed and held the button and connected and when I try to flash the firmware, it says No response from the bootloader, programming: FAILED Can someone help me with what to do with betaflight?


#2

Have a look here


#3

Still doesn’t work, I tried ImpulseRC and also zadig. They both don’t pick up the fc. I tried going in to the device manager and it doesn’tshow anything. Please help.

Then I connect the fc it has a red light and blinking blue light.
When I press hold the button and plug in, it shows twored lights.
Is that supose to happen or?

When I connect other usb it make the sound. but with this it doesn’t make the sound, just lights


#4

Ok check if you trying flash fc with correct fc target.
Restart computer and connect usb cable into different usb socket. If you are using usb hub connect usb cable directly to computer.


#5

When I try to flash, is says this in the logs

Serial port successfully opened with ID: 3
No configuration received within 10 seconds, communication failed
Serial port successfully closed

Other ports says : Failed to open serial port.
I tried all ports

I restarted, tried different computers, different ports… nothing :frowning:
Is it a fault with circuit board? because non of the PCs detect a USB when pluged in


#6

I think its faulty fc. My computer sometimes dont recognize fc but after restar pc its always start working. Check if the usb connector its not become loose on fc ( i rip off twice mine ). Touch solder connection on fc usb socket with solderig iron. Thant will be mine last to do step before give up on fc but one time i fix my vtx by this step. Good luck


#7

pffff… No luck :frowning: Thanks for the help though :slight_smile:


#8

Try flash it without pressing button. Just connect it and pres flash. Can you connect to actual betaflight and change any settings ?


#9

No I can’t connect it/flash. Don’t work either with button pressed or without :frowning:


#10

@UnmannedTech, I was an idiot not seeing if it works before I solder some pins into the board. Am I too late to return it?


#11

Usually we still offer returns/replacements assuming your soldering isn’t what caused the fault. So it usually depends, but if you have been using it correctly and it just died then we should be able to replace it for you. Please just send an email to support with a few photos and a summary of the problem.

But before we go down that route my rule of thumb is this. Does the MCU get hot when just connected via USB? If so then it’s fries and needs replacing, if not then if your FC still shows some LEDs then it’s more likely to be a driver/firmware issue. It’s not a perfect rule but is true for most situations.

So can you try to hold the boot button while powering it on, then try running the impulse RC driver fixer and hopefully it will install some wsfu drivers. Then you should be able to flash new firmware.

Let us know how you get on.


#12

Maybe to late but if it failed to flash then the original firmware should be on, have you tried plugging in and just hitting connect .


#13

Not late but the thing is computer dont detect the usb connection so I cant choose a port in betaflight. I tried on 3 computers. I tried to conmect but one computer dont even show at least one port to choose. This is what it says when I try different ports. One pc don’t even show any ports (only show manual). Most ports says Failed to open serial port. Two says successful but says closed in a few seconds.

2018-10-23 @ 20:27:42 – Loaded release information for configurator from GitHub.
2018-10-23 @ 20:28:05 – Serial port successfully opened with ID: 1
2018-10-23 @ 20:28:15 – No configuration received within 10 seconds, communication failed
2018-10-23 @ 20:28:15 – Serial port successfully closed
2018-10-23 @ 20:28:24 – Failed to open serial port
2018-10-23 @ 20:28:28 – Serial port successfully opened with ID: 2
2018-10-23 @ 20:28:38 – No configuration received within 10 seconds, communication failed
2018-10-23 @ 20:28:38 – Serial port successfully closed
2018-10-23 @ 20:28:41 – Failed to open serial port
2018-10-23 @ 20:28:50 – Failed to open serial port
2018-10-23 @ 20:28:53 – Failed to open serial port
2018-10-23 @ 20:29:01 – Failed to open serial port

lights work fine when connected…
This is normal connect (Constant red light, flahing blue light)

This is when usb connected by holding the button


#14

if you’ve installed cp210x drivers and a port doesn’t show at top when plugged in i would suspect FC fault.
However the lights would appear to show board ok.
do not worry about zadig or impulse drivers yet, that is more to do with firmware flashing.
I use the 405 board and never had problem connecting with only cp210x drivers (to see if working anyway)


#15

My suggestion is that with the board connected to your PC (when the boot button is pressed), run the impulserc driver fixer, as then it will install the DFU driver (different from the VCP drivers when you nomally connect)… Hopefully the app will say that it found the board and installed the DFU drivers. Then close the betaflight app (if its open) and launch it again. In the top right you should now see DFU… so now you can flash the new/correct firmware onto your FC.

Also failing that, when the board is connected with or without the boot button pressed, can you see it in your windows device manager?


#16

Nope I ran impulserc, zadig and checked device manager. non of them picking up the connection.


#17

:cry: then I think the FC is dead… I assume you have tried another PC and USB cable just incase?


#18

yep tried :frowning:


#19

RIP :frowning:. Did you order the FC from us?


#20

Yes I did, I emailed and Cameron was in contact with Matek I think but still waiting for a solution :frowning: