Falcon 250 pro/ failed to open serial port/ cleanflight


#1

Hello everybody, who can help me ???

I just can´t connect to my Eachine Falcon 250 pro.
I tryed everything you can find about it in the internet but nothing worked.
I´m using Windoof 10 and in the hardeware manager I can see that in the USB devices as “CopterControl”. It´s been reconised but if I start Cleanflight or betaflight it dosn´t work. Failed to open serial port. That´s the message I get. Always !!!
I installed all the drivers like in the descriptions you can find and it dosn´t work.
I played around for hours with Zadig and the differend drivers but it just dosn´t work.
What is this ??? I need help !!! I can´t manage it, something goes wrong and I got no Idear !!!
please help !


#2

I´m still trying to hook up to my Falcon 250 pro !!!

Now, it´s kind of funny.
I played around with the drivers and there are two devices in the hardware manager to see,now.
One is shown as “CopterControl (Interface 0) (COM3)”,
the other one is “CopterControl (Interface 2) (COM4)”

Both can be seen in the software Cleanflight ore Betaflight. I can change them (Com3/Com4) but still " Failed to open serial port !"
I just don´t understand why there are two devices of them, now. If I uninstall one ore both of them and restart the computer, it´s been the same. Interface 0 and Interface 2. They just getting reinstalled by connecting the Quad.

If I start Zadig, I can see the two devices like shown in the hardware manager of windows. I can change the drivers successfully but it´s not working with cleanflight. Still, failed to open serial port.
It looks like that there are two devices in the board and they are troubleshooting.
Therefore, I just ripped everything apart and disconnected all the other devices on the board.
I could cry ! Same shit ! Same problems, nothing has changed !!! OK ! Maybe it´s not possible at all to configure my Quad.
I guess I have to get rid of the board and buy another one. One I know it´s possible to connect to it.

Now I think I should´t have bought it !

Yes it flies but that´s it.
The battery alarm goes off when the quad is already down. I have to change that because it´s killing my LiPo´s.
They come down to 2 volts each cell. Not good !!!
I have to change that but how, if I can´t connect to it ???

The next bad thing is that the Eachine VR D2 goggles that came with it are useless. I can´t see shit with it if I wear it ! The screen is to close to the eyes. I can´t focus with the lens in it. So, don´t buy it !
It takes some modification to use this properly.
The lens in it needs to be changed ore it´s housing needs to be made longer.
I just don´t understand what the guys who made this were thinking. They probably never tested it.
I´m really disappointed now !

If anybody has an idear ??? I´don´t !


#3

Now, I know how to flash the CC3D board with OpenPilot. The problem is now that I can´t spin the motors in the config. Only one works. And I can do what I want, I can´t make my receiver working. It´s just not working in any Setting. I think I tried all the setting about PWM / PPM / S-BUS etc. nothing works. If I hook up a servo then it works fine on all channels. Its the board CC3D ! I´m sick of the shit. Nothing works. I purchased a new CC3D board but I have the same Problems. I can´t get it set up. There is always something not working.
I got another board, SPracingF3. Even that has the same problems. Can´t tune the motors and the receiver dosn´t work.
I tryed all possible settings about PPM/PWM just everything for hours. It´s not working.
I the internet I saw videos how they do things with the same stuff I have got, but it´dosn´t work with mine. I have the same settings and it´s not working. Always no motors and no receiver. I also realiced that if you get another receiver they don´t stay bound if you switch them off. Only the one that came with the receiver stays bound when you switch on and off

I thing I just trash it ! I don´t get answers here anyway. Nobody helps me. That´s the end for my Falcon 250 the Wizzarnd X220 and my KingKong. They all don´t work anymore because I can´t configure them that the motors work and the receiver. All of them have the same problem.