CC3D Problem configuring

Hello I am seeking assistance to program a new CC3D flight control board, Let me say I have previously and successfully configured our first one not without initial problems but with help from unmannedtech and it flies well. Using this experience my grandson and I are building a second quadcopter and thinking it would be straight forward we hooked it up clicked on Erase and Upgrade and…nothing. Then a message in red saying it had timed out? We are using the same USB lead and port on the mac as before. we have a constant orange light on and a blue regular flashing light (about 1/2 second on and 1/2 second off) and the other thing I have noticed is that I seem to remember when we configured our first board it also lit up the red light in the Turnigy receiver when plugged into the USB but at my age I don’t trust my memory. Clicking on the firmware icon it says something about doing it manually there seems to be no recognition of the board but the artificial horizon moves when I move the CC3D? Does any of this ramble make any sense to anyone? We’d appreciate any help. Thankyou😢

It sounds like something strange is definitely going on. Did you purchase both your CC3D boards from us? If you try connect your first cc3D board to your computer does that one still work fine on your PC?

But the other suggestion would be to manually reflash the firmware in recovery mode as shown below.

Thankyou for the prompt reply Alex I tried following the procedure but unfortunately with the same results?? Still timing out (see screen shots) I don’t fully understand what the messages mean like “reconnecting telemetry” when the board is still connected? Regarding the other board other than just plugging it in I am reluctant to try and reconfigure it as it works and if I upgrade and erase it may stop that working too?? Any thoughts? If you think I can go through the process without trashing the working board I’ll have a go (No onus on you of course) at least that would eliminate GCS/computer/USB faults, leaving just the new CC3D as faulty.

Alex I eventually bit the bullet and tried configuring my board form scratch and it’s fine so I deduce from that that the new board is indeed faulty in answer to your question about the origin of the boards you were out of stock so I bought them through ebay, however the supplier is being good about it and sent out a replacement. Thankyou for your help.

Happy to hear that and that you managed to get replacements :slight_smile: If you have any other issues just let me know and I will try to help

I recently bought ZMR250 DIY kit from Unmanned Tech. Unfortunately my CC3D does not fire output 2. All four motors will work on outputs 1,3,&4. Using Libre Pilot, I have tried to use output 5 to fire motor 2, through the vehicle tab. Initially I could fire motor 2 using the outpu channel 5 slider on the output tab. But when I used the remote to control the motors, only 1, 3, &4 fired. Now I can no longer control motor 2 using the slider. Although output channel 5 remains allocated to Motor NE, I cannot move the slider anymore. Any suggestions please? All help gratefully received! This was my son’s birthday present on 4/10/16, and he’s getting a bit twitchy now as it still hasn’t flown…

John, I also had a similar problem, but it was my 3rd motor port that would cut in and out. I bought all new ESC’s and motors to have no change. At this point I knew it had to be the board itself. So I have since purchase TWO other CC3D’s, one ATOM and one regular CC3d Rev C yellow cased one and BOTH have either been DOA or unable to connect to USB like the others.
This newest board stays with a solid orange light and a slow pulsing blue light. I try to rescue and it refuses to go into bootloader mode it seems…it will just time out on ‘forcing board into bootloader mode’.

At this point I have had such bad luck with these boards that I am about to just get a damn naze32.

Thanks Lance - sounds like you’ve had some pretty bad luck.
Did you try using port 5 or 6 to run motor 3 on your original board? if so, how did you make that happen? were you using Libre Pilot?

Could you send me a photo of your output banks screen so I can check, on that page you can also change the assignments. So if output 3 is not working you can set the output number 5 or 6 to be for the VTOLmotorSE. I dont have any CC3D quad with me right now (as its in the office) so I can get a quick guide to show you how to do this on Monday, but it does sound like your board is damaged so send us an email with your order number and we will get it fixed/replaced for you.

(In response to your email) Yes John, I am using Librepilot, and I tried to use ports 5 and 6 but could
not get the motor to respond no matter how hard I tried using those ports.
I’ve just received a Naze32 that I will be trying to setup tonight/this
weekend. However I still have plans to use my ONE good CC3D in my flying
wing as it only requires two ports.

And to Unmannedtech, I have tried to reassign ports on the CC3D and the motors wouldn’t spool up on ports 5 or 6, I may have missed something but I don’t know.

My order ID is #24314.
My issue is with output 2, so I have put VTOLmotorNE on output channel 6. on this screen, all 4 motors fire when live testing.

I also get this error message:

regarding ‘RC Input critical’. my i/p config page looks like this:

look forward to hearing from you Alex. PS I’m busy in the week, so only get to play at the weekends :wink:

Ok so its definately an issue with the output on your CC3D so thanks for testing that :tools: , also that error message is because you have the flight modes RC input disabled according to your screenshot, if you enable that channel the message should go away as its saying that you dont have any R/C configured to change flight modes.

As for the CC3D, you can request for us to exchange it for you by logging into your account and on the order screen you can request a return, and instead of expalining the issue just link to this thread and we will get it sorted for you if you dont want to use the CC3D as it is.

Hurrah! We’re up and away. Using the vehicle set-up wizard prevented me re-assigning output port 6 to motor 2. I re-flashed the cc3d and did it all manually, having previously learnt most of the answers from the wizard. All good - except port 2 is definitely DOA. I’m also concerned that the ESCs are configured correctly…where can I do that outside the setup wizard? The fact that the motors fire at very different minimums (1081,1084,1034,1075) suggest there is an issue here. I’ve also not been able to select the zmr250 option from the end of the wizard. Incidentally, here the video says we have a 3s battery, but I have a Tattu 4s 14.8v as sold with the kit.

Next challenge: this little fella is very lively for us (compared to our Sima X5SC). What is the easiest way to use the GCS software to tame the ZMR250 for learner drivers? which calibrations should we alter? Thanks for your advice…

I’m beginning to get frustrated!
This morning I came online to look up buying FPV gear for my son for Christmas. It was then that I noticed this ZMR250 should run with an 11.1v 3S battery pack - mine was shipped which with a 14.8v 4S battery pack @ £13.71 (order number 21314) through a ‘recommended kit’ link in September. This explains why I have a brand new unused 3S charger (order number 24590) and then had to order a second charger for 4S @ £17.55 (order number 25876). So currently I have a duff CC3D, the wrong voltage power pack and charger, and no correct power pack to drive the drone this weekend. I have no idea what damage has been done to the components by the excessive voltage. I hope you are as disappointed as I am. I have wasted significant time and effort with unmatched equipment. I also hope Unmanned Tech are able to resolve this for me without further expense. So far I have spent >£185 with you, and have nothing yet that flies. I look forward to your swift response.

I sorry about the problem here, I am not sure why we would of suggested you use a 4S lipo with the ZMR 250 when the ESC labels say 2-3s on them! but to be fair we do deal with so many quads sometimes we can get abix mixed up, especially when replying to emails late at night!

So I hare just replied to your email you send us with return details, but I suggest you return all the stuff you got from us and myself or Sam will check your ZMR250 and repair anything that has been damaged by over voltage and we will also refund the 4S lipo if you no longer need it. We will then return a fully working zmr 250 quad back to you :slight_smile:

Also it might be best if you can also return your radio control gear so we can bind it to your quad so it will be 100% ready to fly when you get it back.

Hi Alex, thanks for your help. Our ZMR250 is on it’s way to you 1st class post. We had no problem binding the receiver & transmitter, so we’ve kept them here to keep the postage down. Despite the challenges, we’re still keen to go FPV at Christmas if we can get all the right bits from you. Let me know what you find you investigate the quad.

Sure thing, should get it sorted very soon for you, sorry about the problems :frowning:

does it matter if one out of the four motor starts at a higher min

I’ve not had experience with the CC3D but as a general rule you should have all ESC’s calibrated so all motors start, stop, respond the same.
You can calibrate with just the radio TX and RX there’s plenty of videos on YouTube to show you how
Steve :grinning: