CC3d unrecognized help!

cc3d

#1

Started building my first FPV drone. It was going well till I tried to hook my CC3D flight control board to my computer (windows10). Attached is what I get when I connect it to Librepilot or Openpilot. The computer won’t recognize board saying the device malfunctioned. Also I only see one lit bar in the TX and the RX is empty! at the lower right of the software. I’ve tried multiple versions of Openpilot. Anyone have any ideas? Is the CC3D controller bad? Thanks for any help anyone can give.


#2

CC3D and Librepilot/Openpilot are about the oldest FC software going.

You should really be looking at flashing betaflight on to you board if you can.

The chances are you need to install the stm32 drivers to get your computer to work with the FC

https://www.st.com/en/development-tools/stsw-stm32102.html


#3

Disconnect, then Click Upgrade & Erase. Plug in the CC3D when prompted, and this should flash the latest firmware to the FC. Once complete, it should connect without any issues hopefully.


#4

It was just an issue with my computer, thanks for the replies, just deleting the drivers and letting windows install them themselves worked.