CC3D Conroler Problems Connecting to OpenPilot

cc3d
flightcontroller

#1

Finally bought and started building my first FPV drone. It was going well till I tried to hook my CC3D flight control board to my computer (windows10). Attached is what I get when I connect it to Librepilot or Openpilot. The computer won’t recognize board saying the device malfunctioned. Also I never see any lit bars in the TX and RX bars at the lower right of the software. I’ve tried multiple versions of Openpilot. Anyone have any ideas? Is the CC3D controller bad? Thanks for any help anyone can give.


#2

I suggest you double check that you have the correct drivers installed but it looks like your board might be bad :frowning:

One thing to try is to try using the rescue button within librepilot to try recover the board. But if its not being recognised by your PC it means its not even starting up correctly so might not be possible.

Did you buy the CC3D from us? If so send support an email and we should be able to replace it for you if its still within the warranty period.


#3

It appears to be the board for sure. Bought another controller and it connects up fine.