Eachine falcon 250, How to flash and fly with betaflight 2.9.0


#1

i decided to take the plunge and flash betaflight. i had a lot of road blocks along the way. now i have it flying nicely, this guide should be straight forward for you to flash and fly with no (hopefully) issues.

this conversion does require you to change your channels phsyically on your receiver (fs-ia6a [flysky]). reason being, it would not sync my radio controls (fs-i6), also it only seems to allow 1 aux channel.

from this

to this

firstly, you need to either already be flying with librepilot or at least have librepilot installed on your pc.

librepilot ;
https://librepilot.atlassian.net/wiki/display/LPDOC/Downloads

next you need to download the betaflight_2.9.0_CC3D_OPBL.bin ;

to flash betapilot onto the cc3d please watch this video. when you replicate what happens in the video, you’ll need the file you will have downloaded from the link above, the betapilot opbl.bin file. i personally didnt have to have the battery connected to the drone (powering the cc3d), however i did have to use the usb2.0 port ass wouldnt work with usb3.0 ;

next you need to download cleanflight, you can get this from google app store when using google chrome;

now, hopefully you’ll have your falcon connected and recognised by cleanflight.

Remember how we changed the channels in the rx? well, lets get that sorted first, as the rest is pointless if it wont sync with your radio. MAKE SURE YOUR PROPS ARE OFF. PLUG IN YOUR VTX ANTENNA.

go to the “configuration tab” in the section, “receiver mode” check “rx_parallel_pwm” then click save at the bottom of the page

we need to click on the “CLI” tab at the bottom of the screen. here we need to enter commands, 1 set to sync up the radio channels, and the next is to reconfigure the motor mix. as the motor mix for beta/cleanflight is different to the motor mix of the cc3d on the falcon. i didnt realise this at first and my quad kept violently flipping on take off.

so, to remap the channels, copy paste;
MAP EART2143
SAVE

your fc should now save and reboot. if you have difficulties reconnecting, unplg the usb from fc, click the connect button at the top of screen untill it says connect. replug the usb into the fc and try again.

next, back into the cli tab again, we going to change the motormix.


the smaller of the images is what it is, origninally, and needs to be. the larger is what cleanflight thinks it should be.

in cli command, copy paste;
mixer custom
mmix reset
mmix 0 1.0, 1.0, -0.93, -1.0
mmix 1 1.0, -1.0, -0.93, 1.0
mmix 2 1.0, -1.0, 0.93, -1.0
mmix 3 1.0, 1.0, 0.93, 1.0
save

go back to the receiver tabe and check everything does what it should. hopefully you’ll have all 4 flight channels and the 3 position switch on your radio should be working as aux2.

now, thats the tricky stuff done, its just a case of configuring all the settings now.

personally, i have rotated my fc so i can have side access so i dont have to strip the quad down to be able to plug into the usb port. i also have the motor mounts removed.

if you have spun your fc like i have, you will need to add -90 to the yaw axis. this is done in the configuration tab, in the section “board and sensor alignment” if you still have the motor mounts fitted, and want it to hover level instead of drifting forwards you will also need to add -10 on the pitch axis. click save. (click save on every page after changing things)

on the “setup” tab, click “calibrate accellerometer” now hopefully you quad will be doing the same as it shows on screen as you tilt and roll the quad by hand.

next we need to calibrate the esc’s, in the “motors” tab. have your battery removed, click the “i understand the risks” bottom right of the screen and push the master slider upto the top. plug in the battery ad it will beep. once its done beeping, twice when it starts (as it always does when connecting battery) and then another 4 times, then drag the mater slider all the way to the bottom. this should be the calibration complete. now if you move the slider it should make the motors spin. then do one at a time to make sure they spinning the correct direction.

now, go through your settings copying all settings i have pictured below.

go test fly!

to arm, if everything has worked, turn on your radio, switch the 3 postion switch to the bottom and then back upto the top. it will now be armed in horizon mode, the middle postion is acro mode with air mode enabled (motors will spin), the low postion, when throttle is 0 is effectively a failsafe.

DISCLAIMER
THIS WORKED FOR ME, I CANT 100% SAY IT WILL WORK FOR YOU. I DO NOT KNOW HOW TO REVERT BACK TO LIBREPILOT IF IT DOESNT WORK. PLEASE PLEASE BE 100% COMMITED IF YOU ATTEMPT THIS.


Pid's and rates beta flight for naze 32 250 falcon pro rtf
#2

Hi,

I followed your tutorial but i have the SPF3 flight controller and i lost all default configs on my falcon 250 pro.

But still flipping i have done all correctly and my flight controller yaw offset is 90 becaues it points to the right and not left like you. So i think something is wrong with my mmix settings the numbering of the motors. and i used all stock cleanflight pids to make sure the pids where not affecting.

any insight would be great.


#3

Hi. Was you on cleanflight to begin with?

Easiest way to check your motor mix is connect to betaflight/cleanflight whichever your using, go to the motor tab. On bottom right side, check the warning button. Connect a battery and then one by one, Turn up each motor. While doing this check your motor are spinning the correct way and that the correct motor is spinning. Back right is motor 1.

Also did you calibrate the esc’s after reflash?


#4

Hello, I have done all the steps, but after the channel mix and click on “save” I click on motors to test them one by one and I still have the configuration of openpilot! why??? can you help me???


#5

Did you copy paste the above into the cli? Including typing the word save. And not just clicking save


#6

what is the use thise softweres


#7

Hi! Thanks for your help. I follow your advises and i have a issue. The racer flip during take off. I think there is a problem with the CLI command because i removed my motor tilt.
Should i enter this instead

mixer custom
mmix reset
mmix 0 1.0, 1.0, -1, -1.0
mmix 1 1.0, -1.0, -1, 1.0
mmix 2 1.0, -1.0, 1, -1.0
mmix 3 1.0, 1.0, 1, 1.0
save ???

That does correspond 0.93 ???


#8

glad I found this doc. it works well !! my old Falcon 250 flew like a blade with betaflight 2.9.1. really appreciate it.

BTW, could you share the screenshot for “Modes” configuration ? I have not figured out how to set the 3 position switch for Arm, Horizon, Acro and Air mode.


#9

It’s been a while now. But from what I remember. For whatever reason the mod only allows 5 channels. Instead of 6. So I set the swd to channel 5 on the fsi6 itself. Then in flight modes, I set arm to 1200 horizon to 1500 and airmode to 2000. All aux 1. It just means to arm to have the switch down and back up again. Also mean the only way to disarm was to power radio off.