Eachine 250 Pro not Arming motors


#1

Just bought the Eachine 250 pro and have charged all batteries and added batteries to the remote. I power the remote (Eachine I6) on and it connects to the quad, the fpv feed works well and the LED’s work but I cannot switch the motors on. I’m new to this so maybe I’m missing something?

Does anyone have any ideas?


#2

Eachine 250 racer – not arming
I configured a new Eachine 250 racer with OpenPilot GCS and could not get the motors to arm. I have built several quads using Mission Planner software and so am somewhat familiar with quad setups.
I set the following - Welcome > Configuration > Arm Settings > Stick low throttle and Yaw right but it did not work. I have had quads that required lowering the throttle trim all the way to bottom to arm – tried that no luck.
So, I changed the armed settings – Welcome > Configuration > Arm Settings > Always Armed > SAVE - and now works fine.
I do not like Always Armed but OK for now.
Luck, Vince


#3

Thanks for advice I will download open pilot and have a go.In messing with the controller I have in bound it any ideas how to re bind it? Do you just have to plug the little black bins tool into the bind section?


#4

Yes bind your receiver the usual way then connect to flight control board. Open pilot does not include a binding process as some other drone software does.


#5

Ollys,
I just noted that OpenPilot is replaced by LibrePilot - so just install LibrePilot as newer and good forum for problems. Very similar software.
Thanks,
vlaporte


#6

Thanks a lot got the issue sorted! Awesome to see such a friendly and resourceful community!