Cannot Bind FS I6 with Eachine Assassin 180 - Please Help - Going Nuts


#1

Hi there,
Im a newbie and I think I screwed everything up. I cannot, for the life of me, get my Eachine Assassin 180 to bind with the Eachine i6. I bought the banggood special cause a buddy said it would be a good beginner drone. It was working fine out of the box and I was to to calibrate it with Cleanflight. I followed a youtube video on flashing the firmware with a Naze update and blah blah. Now when I turn it on it goes through the motions, the beeps and whatnot. When I unplug the little wire shorter (Sorry, very new to this) the headlights turn off, all the leds flash like crazy and then the back leds flash green. When I try to bind with the wire shorter the transmitter just sits on “RXBinding” and nothing else happens. Ive tried the steps every which what and backwards and cannot get this to work. I can make a youtube video if that helps, I just want to play and crash this guy Here is a link to what is going on:

Maybe just tips on how to reset everything back to factory so I can just play? Any help would be appreciated. Thanks!


#2

Thanks the video makes it easier to try help. One thing I suggest is first to get it to bind you need have everything turned off to start. Then first turn on radio in bind mode (holding bind button), then turn on your reciever/quad with the bind plug inserted and you should see the radio bind to the reciever. Then turn everything off remove bind plug.

If that did not work let me know as there is a setting on the frsky menu you might need to change.

If that did work and your Naze is not picking up reciever you need to connect to pc and check the reciever settings as I think the default in cleanflight after a firmware update is to use ppm receiver, but i think yours is setup as PWM so you just need to change that in the record tab.

Hope that helps


#3

I have the same Problem. After an Firmware update it wont connect again. On my Controller i am Connectet (RX Status is shown) But i can not arm the device. In Settings are PWM enabled… it is just blinking and the green LED on the top is flashing to…
I have no clou whats wrong with it…


#4

Are you certain our rx is bound? Also, when you updated firmware are tou sure you selected the correct target for your Nazi?


#5

Its definitly Connectet. I can Spin the Motors when Failsave ist OFF,(set to SwB Button) but my right Stick has no Funktion, either in Cleanflight or with connectet Copter. But in Controller Option is see movement and the right stick is working. Could be the transmitter be brocken or so?
In Cleanflight i only have 4 AUX Chanels, but Pitch, throttle etc are not working…PWM is enabled, other Configs are not working with Controller…
Greets Ronny


#6

Ok i found a solution: i flashed back to Firmware 1.13.0 and used Cleanflight 2.2.0 (i think)
changed the Settings to stock and now it works with arming and flying.
Thats it… :slight_smile: