Diatone SP3 vtx no video output


#1

Hi all, I’ve just built a GT2 175 using the diatone d-link f3 f/c and SP3 vtx. The f/c is set using uart 2 as the osd with msrp enabled in Betaflight. Tx to RX and vice versa connected from the vtx to the f/c. I’m getting the osd displayed in my Fatsharks but no video. There is 5.7v at the camera (runcam Eagle) and the wires all have good connection. The vtx is powered direct from battery terminals so is getting 4s power and all lights up when connected. The channel selected on the vtx is B8 which is the same is my Club Racer and works fine with that. Any ideas why I can’t get video, other than perhaps a faulty camera. It’s brand new and been fitted tot his build only. Have I missed something or is it likely the camera? Cheers.


#2

Have you selected an output power other than 0? i.e. 25/200/600mW using the button on the SP3? Lights off is 0mW, Blue light is is 25mW and red light is 200mW.

Have you got a wiring diagram to show?

Steve


#3

I am just building the same set up with the Runcam eagle as well, how have you got your wiring for the cam and I will try the same set up and see what happens. How do you power the vtx directly from the battery terminals? is it not powered by the D-link powering the VTX powering the camera from Vout5v ?

Steve


#4

I am having the same issue with my sp3. I have tried 2 known working hs1177 cams but still no out put. I have also changed bands, fequency and power options to no avail.
also when i plug into my pc via usb i am unable to install the driver. I have downloaded and installed the driver and java files from diaton website but i get a yellow (!) in the device manager, i am running windows 10 64bit. Please help?


#5

Hi
It might be worth checking your voltage at the camera, whilst the spec for an HS1177 says they operate as low as 5v in reality not many do. I scratched my head for hours once until I powered from the 12v regulated and filtered supply and it’s worked fine ever since.
(The top voltage on these cams is high, 22v, so no worries about 4S battery packs)

Cheers
Steve :slight_smile:


#6

Hi Stevietee,

where is the 12v supply from on the boards? All i can see is the Vout5v, VoutVCC, and the Vin 2 - 4s on the SP3 and the PDB only has 5v pads?

Thanks.

Steve


#7

i think he means to power the cam from a 12v supply from a pwbd not the sp3 vtx


#8

Hello Steven (Thats 3 of us in this thread now,lol)

Thanks for the input but I dont see a 12v supply on the D-Link PDB? Maybe thats whats causing the issues for people. If I could see one I would power the camera from it as that was my intention with a different PDB I had but it wouldnt fit my build correctly, or as I wanted anyway. If you look at the D-Link it only shows 5v pads or connections.

Thanks,

Steve


#9

im using a matek power board and just tried supplying HS1177 12v power from that and vcc to the sp3 but still no luck. i have contacted diatone and explained my issue and just had this reply.
“Hello Steve,thank for your photo,as this situation,we can offer free repair service,
your version is the newest SP3,on the 600W power(no wind cool) ,the IC temper can’t over
85 ℃,the antenna section, directly connected to the radio IC control section, any static electricity
may cause radio IC to receive damage,about OSD can’t connect,maybe your windows system
driver software reason”

What does (no wind cool)mean?
Any of you guys having issues with connecting to pc?


#10

No wind cool? Do you think they mean its not air cooled sufficiently? On teh matek is there a 12v pad out? In order for my SP3 to power up I had to connect form 5v at UART2 on the D-Link to Vin on the SP3VTX or it wouldnt power! maybe you have to supply 5v in from the Matek PDB as well to the Vin on the SP3? (See diagram above)

Steve


#11

Any further news or comments on this guys?

Steve


#12

My SP3 is connected directly to the battery terminals on the D-link f/c but the cam is powered from the 5v out on the sp-3. I will change it to the vbatt out and see if the extra power makes the cam work. Stalled, there are two voltage outs on the sp-3, one is 5v and the other is battery voltage.


#13

I think they mean it gets too hot and cooks itself.


#14

Output is set yes. I have tried 25 and 200 but still nothing.


#15

Uart three is your rx in Betaflight, I have my osd set to uart 2 with msrp enabled and uart three has serial enabled as I’m using sbus


#16

VoutVVC is battery voltage on the sp-3, as long as your running up to 4s then this would be writhing voltage range


#17

Hello again,

So, you have it set up like in the attached diagram? literally a wire straight from the Battery pads 2 - 6s on the D link to Vin 2 - 4s and the GND? and the Runcam red wire to Vout VCC instead of Vout +5v and the middle GND i.e. not like i have it in the Diagram?

Thanks,


#18

Like this?


#19

Yes just like that, I don’t know if you are running serial receiver so uart3 may not need to be ticked as serial.


#20

Uart two rx to sp-3 tx and uart two tx to sp-3 rx. I will be changing the camera voltage off the sp-3 from 5v supply to the VCC supply to see if this corrects the camera not working issue. That’s my understanding of how these work, if I’m wrong then someone please correct me.