Connecting a matek f405 CTR to FS-iA6B receiver


#21

That is a good video.
I have done what he suggested but also as you said and put the connections to RX2.
The receiver now works great from the transmitter. :slight_smile:
Now I just need to find out how to arm the quad and all should be good from then on.
So, how do I arm it?


#22

I would set up an arm switch

Look at the modes tab within Betaflight.


#23

OK, I have set the ARMs tab to 1225 to 2000 and saved it. Now what?


#24

when you flight the assigned switch…
Does it activated on the screen… (it will light up)


#25

I don’t understand what you just said.


#26

When you switch the assigned switch on your transmitter.

Does it activate on the screen within betaflight… ( it will light up)


#27

I don’t think it does. When you say light up, do you mean the bar will go across to the end?
According to the transmitter, channel 5 id used for fly mode and I cannot change this. Nor do I seem to be able to affect it on the reveiver screen


#28

Try watching this video and see if it helps you

He goes through setting up an arm switch on your TX with betaflight.


#29

Hello Doomed
I will have to leave this for now, it is almost 1:00 am and I am getting very tired. (We old people do that :slight_smile: )
I feel that we have made some good progress, and I will go over the videos again tomorrow.
Thanks to all of you for your help. Even when I make errors I learn a bit more. I now know not to set up ibus on an inverted signal.
Thanks again everyone. I hope you can all continue to educate me later today. (Much later)


#30

maybe a little late but looking like you have tried everything apart from 1 basic check.
when in betaflight on the receiver tab have you got coloured bars upto 1500 on channels, if not reflash firmware .


#31

Hello Dale, thanks for joining in.
I do have coloured bars on all of the aux channels.
On the modes page of Betaflight, all the channels (1 to 6) are able to go full to 2000
I don’t know if the following is any use, but I include it just in case it is, because I still cannot get the motors to arm

Diff all output (click here)

diff all

version

Betaflight / MATEKF405 (MKF4) 3.5.0 Aug 14 2018 / 03:43:51 (1d710afd7) MSP API: 1.40

board_name MATEKF405
manufacturer_id mcu_id 001c00203436470937333638
signature

reset configuration to default settings

defaults nosave

name

resources

mixer mixer TRI

servo

servo mix

feature

feature INFLIGHT_ACC_CAL
feature SERVO_TILT
feature LED_STRIP
feature DISPLAY

beeper

beacon

map

serial

led

color

mode_color

aux

adjrange

rxrange

vtx

rxfail

master

set acc_calibration = 399,-577,-379
set serialrx_provider = IBUS
set min_throttle = 1000
set use_unsynced_pwm = ON
set motor_pwm_protocol = OFF

profile profile 0

profile profile 1

profile profile 2

restore original profile selection profile 0

rateprofile rateprofile 0

rateprofile rateprofile 1

rateprofile rateprofile 2

rateprofile rateprofile 3

rateprofile rateprofile 4

rateprofile rateprofile 5

restore original rateprofile selection rateprofile 0

save confi guration save

I tried to upload my betaflight backup files, but they are json files so I had to rename them to PDFs before I was allowed to send them. You wull need to change the PDF to JSON to read them properly, although they should still be perfectly readable as text files.

BTFL_backup_20181001_172134.pdf (35.7 KB)

Using the above configuration, the only problems that Betaflight tells me about are CLI and MSP; neither of which should be a problem when I am not plugged in to Betaflight


#32

Ok just to get the right…

AUX channels are working as expected now… 1000 - 2000 on the RX Tab

What about your - Roll,Pitch,Yaw and Throttle channels?

Can you do a screenshot of the RX tab and Modes tab?


#33

Hi Doomed
I won’t be able to respond for 4 or 5 days, but I will get back to you with a screen shot


#34

not a problem… I’ll or someone will still be here.


#35

Here are the screenshots you requested.
I should point out that Aux 2 and 3 are only on full (as shown) when I flip switches ‘C’ and ‘D’
The Yaw is actually a connection from a servo motor directly to the RX channel 4. That works perfectly and I can switch the yaw from side to side, going from 1000 to 2000 via the TX.
I also include a shot of the CLI after a STATUS query



#36

You don’t have a switch assigned to arm.

Try setting it to Aux 2
and when you switch it… the yellow marker should move


#37

dont know if fixed yet but wont arm if throttle above idle value even if arming via switch. looks like throttle at 2000.
arm switch better but if running out of aux channels think you can still arm min throttle yaw right,
might be wrong on this point as not used for years.


#38

Hi Doomed and Dale
I have set the arm switch to aux2.
The yellow marker does move and the centre point depends on the position of the switch ‘C’ On the screen with the switch off the marker is at about 1000. Middle position at 1500, 3rd position 2000.
On the motors screen, I notice that the first block is now at zero; this can be moved with the throttle on the transmitter.
On the previous post, I put the throttle to 2000 to show that it works.


#39

So just to refresh, the problem is that you cannot arm?

The quad will not arm if connected to betaflight due to safety. But if it still doesn’t arm while just connected to battery, this article will help narrow down the cause:


#40

It just started working. :smile:
I don’t really know why, it could have to do with my changing the arming range to 1075 - 2025 but I don’t really know.
This is just the beginning of course. I now need to know what I should do about the other things in the modes tab.
Thank you all so much for your help so far, I was getting ready to throw it all away. Now … sunshine all round :sunny: