Bad LiDAR Health


#1

I fitted a Bennewake TF mini onto my quadcopter. I put the necessary settings onto my Pixhack through Mission Planner and on connection ( I used Serial 4 pinouts )Mission Planner came up with Bad LiDAR Health.
I’ve double checked the connections and settings. I’m stumped.
Anybody had the same or similar ?


#2

Are you using it for collision avoidance or altitude estimation? I noticed with my SONAR unit that when I set the PRX_## values to anything other than 0 the Pixhawk is unable to arm, so I stuck with modifying the RNG_FND values instead.


#3

If you get a “Bad LiDAR Health” message in Mission Planner this is caused because the rangefinder isn’t enabled for landing. This is done through the RNGFND_LANDING parameter and if set you should see the message disappear.