Unmanned Tech Pixhawk can't connect to Mission planner

pixhawk

#1

I recently purchased a pixhawk from unmanned tech, this is one produced by them as a clone, while they claim it works the same if not with better components.

Upon receiving the pixhawk i downloaded the arduplane firmware to the board, after i try to connect with mission planner and i always get a timeout, while the pixhawk shows a solid red light.

The com port shows up as a selectable option on mission planner and when i connect to it via terminal i get the usual boot sequence information.

I checked the log on the memory card and it says something along the lines of “no px4io board found”.

I have tried;

  • formating the memory card and trying with that
    -different firmwares, i.e coptor
    -i have tried the reset buttons on the sides of the pixhawk
    -i have borrowed a 3DR brand pixhawk which works perfectly fine

The Board seems to be fine in terms of hardware, the only issue being not being able to connect with mission planner.

Could anyone help me get around this issue?

Thank you


#2

Firstly can you unplug everything from your pixhawk except for the buzzer and safety switch just incase.

Then can you hold in the safety switch while plugging the in USB as this will for the pixhawk into bootloader mode and will then try to force update the PX4 FMU firmware. After a minute or two the beeps should stop and you can reboot your pixhawk.

Hope that helps, if not let me know so we can try a few other things


#3

Hi, Thanks for the reply i tried that today and nothing has changed, i also noticed that the safety button does not light up if that helps,

The terminal shows this when i connect

ArduPilot
adc
batt_smbus
bl_update
ets_airspeed
fmu
hmc5883
irlock
l3gd20
ll40ls
lsm303d
mb12xx
meas_airspeed
mixer
mkblctrl
motor_test
mpu6000
mpu9250
ms5611
mtd
nshterm
oreoled
perf
pwm
pwm_input
px4flow
px4io
reboot
reflect
rgbled
tone_alarm
top
trone
uavcan
uorb
usb_connected
ver
nsh> e[K
nsh> e[K


#4

That fact that the safety swtich does not light up at all makes me think something strange is going on… Do you have another safety swtich to try?


#5

Yes i tried, with a confirmed working switch and still doesn’t work.
Both switches work with 3DR pixhawk.


#6

I do believe you emailed support with your order number so I will create a return for you so we can have a look and replace/repair for pixhawk board.