Unmanned Mini pixhawk - Firmware download and other dificulties

pixhawk

#1

Dear Sirs,

I’m pretty new in this kind of boards so, in advance, please excuse me if any stupid question on these difficulties that I´m facing with my Mini pix:

  1. Mission Planner is refusing to download firmware saying that is not a valid 3DR board. Is there a way overcome this “policy”? Can I use APM Planner and then use mission planner to configure and use telemetry ? (APM Planner and Mission planner parameters are fully compatible ?);

  2. Using the power module (configured by APM Planner 2.0.18) the voltage measuring is OK but I can´t put the current measuring to work. The field “Measured current” (used to obtain calculated values) just disappear next start up and the calculated current become not representative.

  3. I do not have a 3DR radio so I´m using bluetooth adaptor to download config parameters and telemetry but communication freezes after a few minutes (red blinking on APM Planner on PC software) with no data update and no telemetry or configuring data. I tried 2 different bluetooth adaptor modules, different communication speeds up to 19200 connected on telem 1. often, After a series of these freeze events, the communication port telem 1 become stuck even after board reset or power cycle and could be restored only by a full parameter reset done by telem 2 or by usb. Seems like the parameter set became corrupt by communication issues. Any advise ?

As said before, sorry if any stupid question posted.
Thanks in advance !!!


#2

Hi, and no problem about asking any questions, that how we learn :smile:, here are my answers:

1 - That message you can simple dismiss and you can continue to upload the latest firmware onto your board. Its just a warning that 3DR have added to the new mission planner versions as there has been an increase in people selling face pixhawk boards (as official 3DR pixhawk). Since the hardware is all open source its no problem to make clone boards, but you just cant pretend they are made by 3DR. So this is why the message has been added.

2- You cant edit the measured current value directly, but rather the amperes per volt value. More details on how to do that is shown in this video:

3- That does sound strange, and it could be an issue with the bluetooth driver on your computer. Some other people have had the same issue with bluetooth and found that after the uninstalled the bluetooth drivers and downloaded the newest version for their PC the problem was fixed. Also make sure you are using the latest version of mission planner.

Hope that helps, if you have any other questions please let me know.


#3

Alex,
Many thanks !!! updates from my issues :

  1. The download worked fine as you said just dismissing the warning message;

  2. I have tryed similar procedures like this before, the signal that come from power module seems to be really not consistent, even following the calibration procedure indicated by link. I think that could be something related to the poor quality of my power module clone that is similar to this one:
    http://www.instructables.com/id/Safetly-use-CLONE-APM-Power-Modules/

Now I have a “decent clone” that include the BEC and seems to be a bit better. I will try it as soon as possible.

  1. This one sent by you was a really “golden tip”, I updated the Notebook bluetooth driver but another very important adjust (that I found by chance) was to disable the power saving related bluetooth module. I think that power saving policy could be some times powering off the module
    disrupting communication making the data set corrupt some times.

Thanks a lot one more time!!!