Mini Pixhawck not connecting to Mission PLanner


#1

HI,
I recently bought a Pixhawk mini autopilot and now I am trying to connect it to mission board, but somehow it fails all the time. I connect autopilot to the computer and it makes the sound and blue light is flashing on the board and the red switch button as well. I choose one of the COM ports but it does not give a specific one, then i choose arduplane mission and it asks do I want to install Firmware. Then it asks is it APM2+, press NO, asks is is it PX4/Pixhawk, tried answering yes and no, then it starts to download and shows message to unplug, press OK and connect device and then gives error message No response from board. At this point have no idea what I am doing wrong. Is there anything you can suggest?


#2

Hmm does sound like something is not quite right. Are you able to confirm you have the correct driver installed? If you go to your device manager with the autopilot connected can you see it listed there?


#3

When I connected autopilot to my PC it did not recognize the device and it was not listed in the device manager like normally a USB stick would be!


#4

managed to connect and pc recognized device as px4, now only issue when I click connect it says no GPS an as well no any LED is flashing on it. Does it sound right?


#5

Sorry for many reply posts, just have been going through things and they start to work. I have got till point where I calibrate accelometer. I do as planner asks but after calibration is done it says Calibration Failed. tried to do it many times but nothings seems to work. Is there anything you can advice? Many Thaks


#6

Happy to see you made some progress. OK let’s try things one at a time.

1- for the GPS module please make sure that it’s connected correctly to the minipix as it’s easy to get the connectors the wrong way around.

2- for accel calibration make sure that you have a level surface and there is no motion before you click next. If that doesn’t work it might be best to try reset the board but loading arduplane onto it and then arducopter again. I have had something similar happen before and spent an entire afternoon trying to figure out what was wrong, but after a reset it was perfect. There are hundreds of parameters that you can change and sometimes if one of them are wrong it can mess things up, so best to start with a reset on your pixhawk.