Compass Calibration Unexpected Error


#1

Hi all,

I am having a problem to calibrate the compass (external and internal). I am using Arduplane 3.8.4 and Mission Planner 1.3.52

As soon as I clicked ‘OK’ to start the live calibration, the calibration window stopped and show there was unexpected error. I tried both by connecting Pixhawk 2.1 to USB and through telemetry but the result was the same. I checked the status window and parameter list, it seemed like Pixhawk 2.1 detected the external compass and the internal compass.

Really hope to solve this problem soon.


#2

Are you able to test on another pc, as that seems like a mission planner bug. Other I suggest you reinstall the software and make sure you run it as administrator.


#3

Hi Alex,

Thank you! Yes, I tried on another pc and it worked.

I update my MP to beta and it solved the problem.


#4

I’ve had this problem and it was a bad micro usb cable did you try a new data cable


#5

same the problem i’ve, please help me to debug this, i’ve changed the data cable but no gain! i’m using v1.3.52 on 2.8apm help me


#6


help


#7

I’m new! Plz also guide me that how make sure that we have already firmware on a board and we no need to do install again…


#8

As mentioned by Alex, do you able to do calibration on another pc?
or reinstall the MP software?

I solved it by updating my MP to beta