Accelerometer Calibration


#1

Hello,

I am having a problem calibrating the accelerometer. I have tried many times and it just says its failed.

Here is exactly what I did:

  1. I have removed pixhawk from the y6 frame completely, and removed all connections to it except for the buzzer, the switch and the USB cable.
  2. I connect the USB cable to my computer, then I hear buzzer sound indicating it started ok.
  3. Started the MP, select the Terminal Tab, select the PX4/PIXHAWK option and press the Connect button, then it tells me that PIXHAWK rebooted, then I get ArduCopter v3.1.5 prompt.
  4. I entered setup, then accel command,
  5. I placed PIXHAWK on my desk facing up with the white arrow pointing away from me,
  6. When I see the prompt "Place vehicle level and press any key, I pressed a key right away because the PIXHAWK is already positioned correctly.
  7. When I see the prompt “Place vehicle on its LEFT side”, I turn the PIXHAWK to rest on the left long edge (with the white still pointing away from me), make sure it is stable before pressing a key.
  8. When I see the prompt “Place vehicle on its RIGHT side”, I turn the PIXHAWK to rest on the right long edge (with the white arrow still pointing away from me), make sure it is stable before pressing the return key.
  9. When I see the prompt “Place vehicle nose DOWN”, I turn the PIXHAWK to rest on top short edge (with the White arrow pointing down toward the table), wait for it to be stable before pressing the return key,
  10. When I see the prompt “Place vehicle nose UP”, I turn the PIXHAWK to rest on the bottom short edge (with the White arrow pointing upward), wait for it to be stable before pressing the return key.
  11. When I see the promt “Place vehicle on its back”, I turn the PIXHAWK upside down, (with the white arrow is now at the bottom contacting the table), wait for it to be stable before pressing the return key.

After all this work, I still get the error message “Calibration FAILED”.

Again, am I doing anything wrong, or is the unit defective?

I am using a mac so using AMP 2.0

Thanks


#2

I know that a few Mac users have had a couple issues with the initial calibration, which is usually resolved if you can run the initial config on a windows PC, or by using a virtual machine. Over time I believe the mission planner 2 will include the setup wizard.

Otherwise if you feel like the sensors might be faulty my suggestion would be to try and test that the sensors are actually working properly by going to the terminal screen and typing:

tests
ins

Then move your copter around and you should see the numbers changing, but if there was a fault it will tell you here, or you will not see any numbers changing. If you are not sure then just send me a screenshot as you are moving the pixhawk board and I can have a look.

However is there any reason why you are not


#3

Hello,

I dont have Windows PC, or virtual machine, I’d have to ask a friend. So would that mean that every time I needed to do a calibration I’d need to use a Windows PC?

The APM 2.0 does have an ‘initial setup’ icon, surely that is the equivalent of ‘setup wizard’ no? I have taken a screenshot.

RE the commands, how do I get into terminal? I have disconnected the MAV001 connection. Then the ‘connect’ button becomes available for the terminal, but when I try to connect I get an error. Screenshot also attached.

When I am in the flight data area, I see readings being produced by the accelerometer. So seems to be working, just readings are wrong as its not calibrated.

Thanks


#4

Yes you are correct, I forgot about the initial setup icon as I mostly use the APM planner software on windows (as I don’t own any apple products). And the fact that the HUD moves correctly when you move the pixhawk. So I am fairy certain its just an issue with the software.

However I suggest you still try run the calibration from the terminal screen (button on the top menu), I see you posted a screenshot of it with an error dialog. I am not sure why that occurred but that would suggest why the accelerometer calibration is not working. You might want to try reinstating the mission planner, or try connecting via terminal before you connect to the board the normal way after you have rebooted your computer.

Hope that helps


#5

Hi,

I re-installed APM 2.0 to no avail. I then installed the MIssion Planner software into a PC and repeated steps after loading the firmware. I had the same problem sadly.

I didnt try terminal in Windows, but on Mac, no matter what I try, I cannot get into terminal.

THanks

Stuart


#6

Hi,

Ok I managed to get terminal working in Windows and Mac. Just needed to change Baud rate. So I get all the live values being shows when running

test
ins

So that seems to work fine.


#7

That is rather strange, but happy to hear you managed to connect to terminal, I totaly forgot to mention about the buad rate issue! :blush:. Once connected to terminal you could also try to run the accel calibration by typing:

setup
level

However here are some other suggestions you can try.

1 - We had a similar error from another customer which was caused by them using the wrong GPS cable, easy mistake as you need to use the 6pin cable, and not a 5pin one which you use to connect the GPS to APM.

2 - I am finding it abit hard to read the values from the INS test in the terminal but one more thing to check - once you have connected to your board with mission planner is to check the flight data (located under the status tab below the heads up display). On this screen check the az value when your board is level you should get a reading about -1000 ±100, assuming you have not yet calibrated your accelerometer. If you are getting something significantly different please let me know.

3 - Lastly one more thing to try would be to format the SD card, and load another firmware onto the board, if you are using arducopter, try load arduplane and then go back to the arducopter firmware just to make sure everything has been written to the board correctly.


#8

Hello,

The terminal in APM 2.0 is odd. It sometimes needs several reboots of the Pixhawk before it responds. Just get lots of weird characters on the screen. I wonder if that has something to do with this problem.

When I go into setup, either on Misson planner terminal on a PC or from APM 2.0 on the mac, there is no ‘levels’ command. Please see the screenshots.

  1. Well I have no plugged the GPS module in at this stage as I just want to keep it simple. I was trying at first with the GPS / Compass module, but decided to remove it for the purposes of simplification.

  2. AZ value is -1164

  3. I have tried changing to plane firmware and back. Tried reloading firmware many times now in both OSX and PC.

Not having much luck here, but thanks for your help

Stuart


#9

Here is a clearer image of terminal output of test ins


#10

Here is a clearer image of the status and AZ value:


#11

From the sounds of it something weird is definately going on with your board. My suggestion would be to send us an email with your order number and we can sort out a return/replacement to see what is wrong with the board. I saw in the first photo you attached of the terminal that you had some weird characters showing up which is strange indeed, it could be something to do with a dodgy USB cable, or connection somewhere.


#12

I just tried with another USB cable just in case. Wouldn’t even let me begin the calibration and again with Terminal some odd characters.

I’d expect if it was connection software, that the problem would only have happen in OSX though it also happens in Windows too.

Thanks I have sent an email with order number


#13

Hello,

Thanks very much for sending a replacement Pixhawk. Soon as I ran the calibration is succeeded. Happy days.

Just having a problem with arming it now. I will open a new topic for that.

Thanks for all the help

Stuart