APM 2.8 BAD compass health M8N

gps

#1

I hav an APM 2.8 and trying to settup the external compass, after live calibration is successfull the a pm will not pick up any satellites. (BAD COMPASS HEALTH) is displayed. I hav tryed 2 different GPS/compass’s and still the same result. I hav the jumper taken out for the external compass and selected (APM external compass) in the initial settup window. Any help please. Do I need to program the GPS to my region


#2

Are you mounting your GPS far away from any other electronic items (on a mast for example)? As possibly the location of your GPS is not good enough and getting interference. Also double check the cables are also not going past any higher voltage sources.

The other issue could be your compass orientation is not set correctly in mission planner?


#3

Thanks for the quick response, I’m building a delta wing with one esc at least 15 cm away and yes it’s mounted on a tower at the front of the fuselage.


#4

The APM unit and GPS orientation are the same.


#5

I hav tryed using another GPS thinking it was the wiring or unit that was at fault, also running the cable away from anything else didn’t change anything.


#6

Ok how do I check the orientation is correct in M planner?
Thanks again for your time


#7

Setting new offsets for compass also fails. And I hav just read that when using 3.2.1 onto the board try using 1.3.9 mission planner firmware as it is closer to the release date . I will try this and get back to you


#8

Ok hope this helps someone, I uploaded rover firmware and then went back and uploaded plane, and now I’m able to calibrate the compass and save the offsets to the board. So one problem solved now just will not pick up any satellites, (bad compass health ) (bad GPS health)


#9

Hmm thanks for sharing how you solved one problem, but if you still get bad compass health then it could still be that there is some interference somewhere. When you calibrated where you close to any large metal objects or a power line? Or maybe you are not using the external compass, but rather the one built into APM?

As for GPS, are you outside with a clear view of the sky when not picking up any satellites :satellite_orbital: ?


#10

I live in the country and calibrating with no power poles or buildings in sight.
I’m now in full parameter list, (AHRS orientation) and just making sure it’s correct. Do you know the number that corresponds with a standard orientation? Default was (0)


#11

I have not used an APM for a good year now so cant recall off hand which orientation you need to select, but here is how you can check yourself by checking the full status view on the main screen of mission planner to get the correct orientation. Otherwise its probably fastest to simply select the quick settings for APM with external compass?

Checking Compass Orientation

  • Ensure your AHRS_ORIENT parameter is correct. This will ensure that your internal compass’ orientation will be correct
  • When rotating your aircraft through all axes each of the compasses should move in the same direction, and should be of approximately the same values
  • Northern Hemisphere: - Z-component should be positive - when pitching the vehicle down, the X component should increase in value - when rolling the vehicle right, the Y component should increase in value
  • Southern Hemisphere: - Z-component should be negative - when pitching the vehicle down, the X component should decrease in value - when rolling the vehicle right, the Y component should decrease in value

#12

Ok thanks, in what section of mission planner do I need to be in to check the values for XYZ ?


#13

I hav also loaded the 1.3.9 mission planner software and re-done the compass calibration, still (no GPS fix) (bad compass health)


#14

I can see the roll, pitch, and yaw values change when I move the unit but I’m not sure what XYZ is


#15

It’s on the main screen just below the HUD, there is a status yatab, within that you will see mag x,y,z measurements.


#16

Ok they are corresponding correctly, I’m almost done with this board, it has to b faulty,


#17

Hi, if you are indeed using the external compass then it has nothing to do with your APM board (most of the time), but it is rather unlikely that both GPS modules you have are faulty, so the issue could be with your mounting of your quadcopter.

Or the other issue could be that you are still using the internal APM compass, so you can check this by looking at the status again, but if you just mode the GPS module, does the compass settings change, or you could just try moving APM with GPS module stationary to confirm you are indeed using an external compass.

If you did buy your APM from us, just send support an email along with a link to this conversation and your order number so we can look into this further as we should be able to replace this for you.


#18

Ok I had a sleep and gained some more patients :wink: is there any point putting the jumper back in and trying the internal compass just to C if that will work?


#19

This setup is a delta wing with one esc @ the back of the unit


#20

Ok I think I was looking in the wrong place for status. I just need to make sure I hav this 100 % before I move on.