APM 2.6 (with ublox lea-6m gps) loiter/rtl not working

apm
multirotor

#1

I think my GPS is not working right with my APM. When it is connected to 10 (yes, TEN) satellites and connected to my computer it says it’s moving around a lot when it isn’t. When I took it for a flight the first time I put it into loiter mode. This is what happened: https://youtu.be/oC3Q6Y9aE7c. Not very successful, as the loiter moves aggressively to the left before I corrected it. Later that flight, it got to low battery and tried to RTL, ramming into stuff on the way before finally catching its leg on the deck and flipping upside down, motors still attempting to spin. I have the compass set to apm 2.5 with external compass because it’s the closest available option to what I have, even though it isn’t quite the same thing (it’s on rotation roll 180.) I also noticed that when I turn it, even on rotation roll 180 it points north and south correctly but ne = nw, e = w, se = sw. In my most recent flight, I tried to just fly it normally and do about the same thing as I did in the video. It triggered a failsafe, even though my transmitter was close to the drone, on, well connected, and the battery had a full charge. Instead of going down and cutting power, the drone went up and cut power, leading to a snapped GPS mount. I am currently working on fixing that mount. I did all the necessary calibrations that mission planner had me do in the “wizard.” Do you guys have ideas as to what else I can do, or should I try to return this item? Here is the flight log for that most recent flight:

Log File C:\Users\Matthew Moore\AppData\Local\Temp\tmpADCC.tmp.log
Size (kb) 92.5341796875
No of lines 1562
Duration 2 days, 21:42:46
Vehicletype ArduCopter
Firmware Version V3.2.1
Firmware Hash 36b405fb
Hardware Type
Free Mem 0
Skipped Lines 0

Test: Autotune = NA -
Test: Balance/Twist = NA -
Test: Brownout = GOOD -
Test: Compass = GOOD - No MAG data, unable to test mag_field interference

Test: Dupe Log Data = GOOD -
Test: Empty = GOOD -
Test: Event/Failsafe = FAIL - ERRs found: FLT_MODE GPS
Test: GPS = FAIL - Min satellites: 0, Max HDop: 2.31
Test: IMU Mismatch = UNKNOWN - No IMU log data
Test: Parameters = GOOD -
Test: PM = NA -
Test: Pitch/Roll = NA -
Test: Thrust = NA -
Test: VCC = GOOD -


#2

Did you made the correct compass calibration ?
In the log file I see "No MAG data ".
If you did it do it again but in open field with Mission Planner.


#3

One more thing : DON’T use wizard on MP.
See if you as correct option compass 1 or 2. Ublox LEA 6M as compass ?


#4

I found the answer: I did the compass motor calibration and now the GPS is accurate within 2 feet. Thanks for helping!