Apm 2.6 unstable

apm

#1

Please can some one help me
Im new at APM 2.6
By quad fly strange at all modes i do not know
Also did not fly as the waypoint i did at mission planner .
I fly it in wendy day but it did not hold position at all not even little


#2

Could you please try to explain the exact issue in abit more detail so we can try figure out what the problem is. Flying strange could be a thousand reasons. Can you please explain how you set everything up, have you gone though all the pre-flight checks etc…Can you also provide some mode details about what quadcopter you are using aswell.


#3

( my amp 2.6 without 3dr air telemetry )
Indoor little stablty but outdoor with little wind every thing change .
1 / I start fly normally In stablize mode take off stable without problem but when i havor about 15 meter it start driffting away for both sides right and left and i can not hold it even with my transmitter stick .
2 / Then i try loiter mode with 3d gps lock it fly by itself i want able to bring it back like it did not response to my radio signal till i switch back to stiablize mode .
3/ i tried to use waypoint that i write on my apm very simple waypoint but when i change the mode to auto it directly fly very fast to the right side to the ground not response to my radio but i avoid crashing by switch to stebalize at last moment .
4/ The second day i tried att hold , position hold stablize and loiter again but without holding position at all drifting and hard to fly


#4

It could be a problem with your compass interference. Have you performed a compass calibration? And can you send a photo of how you have mounted and connected your GPS module?

Lastly would it be possible to send a log file for one of your flights and I can have a look to see if something else is wrong.


#5

Check this two pictures

Uploading…


#6

From the photos it does seem like everything is mounted ok, the GPS/Compass are on a mast away from interference. The APM is mounted onto a anti vibration plate. My only other suggestion would be to double check your compass calibration, and other settings again. It might be worth loading the firmware onto the APM again and starting from the beginning.

Otherwise can you send me the log files from your flight so I can have a look to see if I can figure out what is causing the problems?


#7

Can u please give me your email so i can send the log to u


#8

You should be able to zip it and attach it to this thread, but if you dont want to share it with everyone just send me a direct message with the attachment


#9

Sorry it does not mean i do not want to share it but i could not upload it here i will to zip it and send it again


#10

ArdupilotPlanner.zip (1.9 KB)


#11

Sorry about the delays in getting back to you. Could you rather send the .bin log file which includes all the data. You can also try the APM auto analysis to see if there are common problems with your setup.