Babyhawk does not see XM+ receiver in betaflight configurator

babyhawk

#1

Receiver in Betaflight does not show any signs of activity, same in Models - switches are not responding.

New to this art will appreciate any advice. Thanks.

Babyhawk BNF, FrSky XM+, Taranis X9D+, Computer/MAC/OSX-10.13

Bound Taranis with XM+ - solid green
Tried different FC firmware updates and older betaflight configurator as well.
In betaflight
ports: UART3/serial,
configuration/receiver mode:Serial-based receiver,
configuration/Serial Receiver Provider: SBUS


#2

Have you tried flashing a new Firmware onto the XM+ ?

I got a new XM+ the other day… It worked with BF and my X9D+ out of the box but it was a firmware version behind.

Also what FC do you have?


#3

That’s the only thing I have not tried! Will have to un-solder XM+ from controller :frowning: and try. Thanks for the hint.


#4

Doc said FC is F3 Femto


#5

@sletrc42

you connected up like this?

※UART3 (RX3)
Use for Spektrum Satellite RX, Spektrum 1024/2048, SBUS, XBUS, SumD and SumH RX, etc.

https://www.unmannedtechshop.co.uk/emax-f3-femto-flight-controller/


#6

Could not flash XM+ firmware taranis has not recognize the device.


#7

Yes, exactly. Also on some FC firmware versions i get solid blue and flashing red, but could find what does it mean.


#8

Can you get us some pictures of the wiring and setup of the babyhawk?

Sounds strange…

Where did you get the XM+ from?
Did it come with the babyhawk?


#9

It turned out to be dead/burned XM+, put a new one and worked immediately. May be I fried it by static or it was dead to start with.


#10

Happy to hear you figured it out, and sorry to hear it was a failed RX :frowning: